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C8051F32X DEVELOPMENT KIT USER ’S GUIDE

1.  Kit Contents
The C8051F32x Development Kit contains the following items:

• C8051F320 Target Board
• C8051Fxxx Development Kit Quick-Start Guide
• Silicon Laboratories IDE and Product Information CD-ROM. CD content includes:

• Silicon Laboratories Integrated Development Environment (IDE)
• Keil 8051 Development Tools (macro assembler, linker, evaluation ‘C’ compiler)
• Source code examples and register definition files
• Documentation
• C8051F32x Development Kit User’s Guide (this document)

• AC to DC Power Adapter
• USB Debug Adapter (USB to Debug Interface)
• USB Cable

2.  Hardware Setup using a USB Debug Adapter
The target board is connected to a PC running the Silicon Laboratories IDE via the USB Debug Adapter as shown
in Figure 1.

1. Connect the USB Debug Adapter to the DEBUG connector on the target board with the 10-pin ribbon cable.
2. Connect one end of the USB cable to the USB connector on the USB Debug Adapter. 
3. Connect the other end of the USB cable to a USB Port on the PC.
4. Connect the ac/dc power adapter to power jack P1 on the target board.

Notes:
• Use the Reset button in the IDE to reset the target when connected using a USB Debug Adapter.
• Remove power from the target board and the USB Debug Adapter before connecting or disconnecting the 

ribbon cable from the target board. Connecting or disconnecting the cable when the devices have power can 
damage the device and/or the USB Debug Adapter.

 

Figure 1. Hardware Setup using a USB Debug Adapter
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3.  Software Setup
The included CD-ROM contains the Silicon Laboratories Integrated Development Environment (IDE), Keil software
8051 tools and additional documentation. Insert the CD-ROM into your PC’s CD-ROM drive. An installer will
automatically launch, allowing you to install the IDE software or read documentation by clicking buttons on the
Installation Panel. If the installer does not automatically start when you insert the CD-ROM, run autorun.exe found
in the root directory of the CD-ROM. Refer to the readme.txt file on the CD-ROM for the latest information
regarding known IDE problems and restrictions.

4.  Silicon Laboratories Integrated Development Environment
The Silicon Laboratories IDE integrates a source-code editor, source-level debugger and in-system Flash
programmer. The use of third-party compilers and assemblers is also supported. This development kit includes the
Keil Software A51 macro assembler, BL51 linker and evaluation version C51 ‘C’ compiler. These tools can be used
from within the Silicon Laboratories IDE.

4.1.  System Requirements
The Silicon Laboratories IDE requirements:

• Pentium-class host PC running Microsoft Windows 98SE or later.
• One available COM or USB port.
• 64 MB RAM and 40 MB free HD space recommended.

4.2.  Assembler and Linker
A full-version Keil A51 macro assembler and BL51 banking linker are included with the development kit and are
installed during IDE installation. The complete assembler and linker reference manual can be found under the Help
menu in the IDE or in the “SiLabs\MCU\hlp” directory (A51.pdf).

4.3.  Evaluation C51 ‘C’ Compiler
An evaluation version of the Keil C51 ‘C’ compiler is included with the development kit and is installed during IDE
installation. The evaluation version of the C51 compiler is the same as the full professional version except code
size is limited to 4 kB and the floating point library is not included. The C51 compiler reference manual can be
found under the Help menu in the IDE or in the “SiLabs\MCU\hlp” directory (C51.pdf).

4.4.  Using the Keil Software 8051 Tools with the Silicon Laboratories IDE
To perform source-level debugging with the IDE, you must configure the Keil 8051 tools to generate an absolute
object file in the OMF-51 format with object extensions and debug records enabled. You may build the OMF-51
absolute object file by calling the Keil 8051 tools at the command line (e.g. batch file or make file) or by using the
project manager built into the IDE. The default configuration when using the Silicon Laboratories IDE project
manager enables object extension and debug record generation. Refer to Applications Note “AN104: Integrating
Keil 8051 Tools Into the Silicon Labs IDE” in the “SiLabs\MCU\Documentation\Appnotes” directory on the CD-
ROM for additional information on using the Keil 8051 tools with the Silicon Laboratories IDE. 
To build an absolute object file using the Silicon Laboratories IDE project manager, you must first create a project.
A project consists of a set of files, IDE configuration, debug views, and a target build configuration (list of files and
tool configurations used as input to the assembler, compiler, and linker when building an output object file).
The following sections illustrate the steps necessary to manually create a project with one or more source files,
build a program and download the program to the target in preparation for debugging. (The IDE will automatically
create a single-file project using the currently open and active source file if you select Build/Make Project before a
project is defined.) 
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4.4.1. Creating a New Project
1. Select Project→New Project to open a new project and reset all configuration settings to default.

2. Select File→New File to open an editor window. Create your source file(s) and save the file(s) with a rec-
ognized extension, such as .c, .h, or .asm, to enable color syntax highlighting.

3. Right-click on “New Project” in the Project Window. Select Add files to project. Select files in the file
browser and click Open. Continue adding files until all project files have been added.

4. For each of the files in the Project Window that you want assembled, compiled and linked into the target
build, right-click on the file name and select Add file to build. Each file will be assembled or compiled as
appropriate (based on file extension) and linked into the build of the absolute object file.

Note: If a project contains a large number of files, the “Group” feature of the IDE can be used to organize. 
Right-click on “New Project” in the Project Window. Select Add Groups to project. Add pre-defined 
groups or add customized groups. Right-click on the group name and choose Add file to group. Select files 
to be added. Continue adding files until all project files have been added.

4.4.2. Building and Downloading the Program for Debugging
1. Once all source files have been added to the target build, build the project by clicking on the Build/Make

Project button in the toolbar or selecting Project→Build/Make Project from the menu.

Note: After the project has been built the first time, the Build/Make Project command will only build the 
files that have been changed since the previous build. To rebuild all files and project dependencies, click 
on the Rebuild All button in the toolbar or select Project→Rebuild All from the menu.

2. Before connecting to the target device, several connection options may need to be set. Open the
Connection Options window by selecting Options→Connection Options... in the IDE menu. First, select
the appropriate adapter in the “Serial Adapter” section. Next, the correct “Debug Interface” must be selected.
C8051F32x family devices use the Silicon Labs 2-wire (C2) debug interface. Once all the selections are
made, click the OK button to close the window. 

3. Click the Connect button in the toolbar or select Debug→Connect from the menu to connect to the device. 

4. Download the project to the target by clicking the Download Code button in the toolbar.

Note: To enable automatic downloading if the program build is successful select Enable automatic con-
nect/download after build in the Project→Target Build Configuration dialog. If errors occur during the 
build process, the IDE will not attempt the download.

5. Save the project when finished with the debug session to preserve the current target build configuration,
editor settings and the location of all open debug views. To save the project, select Project->Save Project
As... from the menu. Create a new name for the project and click on Save.
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5.  Example Source Code
Example source code and register definition files are provided in the “SiLabs\MCU\Examples\C8051F32x”
directory during IDE installation. These files may be used as a template for code development. Example
applications include a blinking LED example which configures the green LED on the target board to blink at a fixed
rate. A Universal Serial Bus (USB) application example is also included with the C8051F32x development kit.

5.1.  Register Definition Files
Register definition files C8051F320.inc and C8051F320.h define all SFR registers and bit-addressable control/
status bits. They are installed into the “SiLabs\MCU\Examples\C8051F32x” directory during IDE installation. The
register and bit names are identical to those used in the C8051F32x datasheet. Both register definition files are
also installed in the default search path used by the Keil Software 8051 tools. Therefore, when using the Keil 8051
tools included with the development kit (A51, C51), it is not necessary to copy a register definition file to each
project’s file directory. 

5.2.  Blinking LED Example
The example source files blink.asm and blinky.c show examples of several basic C8051F32x functions. These
include; disabling the watchdog timer (WDT), configuring the Port I/O crossbar, configuring a timer for an interrupt
routine, initializing the system clock, and configuring a GPIO port. When compiled/assembled and linked this
program flashes the green LED on the C8051F320 target board about five times a second using the interrupt
handler with a C8051F320 timer. 

5.3.  Universal Serial Bus (USB) Application Example
The included USB application example requires Windows 98SE/2000/XP operating system. This example consists
of three parts, firmware running on the C8051F320 device, a USB device driver running on the host PC, and a host
application. The host application communicates with the C8051F320 via USB, allowing the user to view and to
change the state of several I/O peripherals on the C8051F320 target board. The example files can be found in the
“SiLabs\MCU\Examples\C8051F32x\C\USB_INT” directory. Located in this directory is the project file for the
firmware, the USB driver files, and the host application executable. In addition, three subdirectories are provided
that contain the source code for each part of the example application; Host Application Source, Driver Source, and
Firmware. Use the following instructions to set up the example USB firmware, install the USB driver, and then run
the example host application. 
After the target board is connected to the host computer via USB, the example application enumerates and sends
data between the target and the host application using Endpoint 0, 1, and 2. The Endpoint 0 packets are control
packets as defined in Chapter 9 of the Universal Serial Bus Specification, version 2.0. Endpoints 1 and 2 are used
for data IN and OUT, respectively. These data packets consist of 8 bytes used to denote the current status of the
buttons, LEDs, Potentiometer, and logic levels of various port pins on the target board. Accessing the USB core
(i.e., accessing the USB registers and moving data to and from the Endpoint FIFOs on the target board) is
documented in Silicon Laboratories’ C8051F32x datasheet.
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5.3.1. Setting-up the Firmware
1. Set up the hardware on the C8051F320 target board according to the instructions in Section 2.

2. Create a project using the following steps.
a. Open the Silicon Laboratories IDE.
b. Click on the Project→Open Project... option in the IDE menus.
c. Answer No to the following message: 

Not all project windows can be restored if not connected.
Do you want to connect now?

d. Select the USB__Int.wsp project, located by default in the SiLabs\MCU\Exam-
ples\C8051F32x\C\USB_INT directory, and click the Open button.

e. Click the Build/Make Project button in the IDE toolbar.
f. The project should now be compiled and linked successfully, with no errors.

g. Connect to the device by clicking the Connect button on the IDE toolbar.

h. Download the project to the target by clicking the Download Code button in the IDE toolbar.

3. Begin program execution on the target by either of the following methods:
a. Click the Go button in the IDE toolbar. 
b. Disconnect the IDE from the device by pressing the Disconnect button on the toolbar. Next, press 

the Reset button on the C8051F320 target board.
5.3.2. Installing the USB Driver

1. Connect the USB cable between the host computer and the C8051F320 target board, as shown in
Figure 1. See Figure 2 on page 6 for the location of the USB connector. 

2. At this point, Windows should notify you it has found new hardware and prompt you with a Found New 
Hardware wizard. Press the Next button.

3. Select Search for a suitable driver for my device (recommended) and press the Next button.

4. Select Specify a location under “Optional search locations:” and press the Next button.

5. Press the Browse button to locate the SiLabsInt.inf driver installation file, located by default in the 
“SiLabs\MCU\Examples\C8051F320\C\USB_INT” directory. Once this file is selected press the OK button.

6. Verify that the correct path and filename are shown and press the Next button.

7. Press the Finish button. 

5.3.3. Running the Host Application
1. Once firmware has been downloaded to the target board and the driver has been installed successfully, run

the USBTest.exe example application located by default in the “SiLabs\MCU\Exam-
ples\C8051F320\C\USB_INT” directory.

2. The USBTest application will display the status of the potentiometer, the temperature sensor, the two 
switches, and the lower four bits of Port 0.

3. The application also includes check boxes for turning on the two LEDs and changing the logic levels on the 
lower four bits of Port 1.

4. If any of the application functions do not operate correctly, verify shorting blocks are installed at the follow-
ing positions: J3[1-2] (P2.0 Switch), J3[3-4] (P2.1 Switch), J3[5-6] (P2.2 LED), J3[7-8] (P2.3 LED), J9 
(P0.2), J10 (P0.3) and J13 (P1.7 Potentiometer). 

5. See Figure 2 on page 6 for the location of headers, LEDs, switches, and potentiometer.

Note: The C8051F320 target board has the ability to be powered through the USB cable. To enable the USB powered mode,
move the shorting block located at header J2 to header J11. 
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6.  Target Board
The C8051F32x Development Kit includes a target board with a C8051F320 device pre-installed for evaluation and
preliminary software development. Numerous input/output (I/O) connections are provided to facilitate prototyping
using the target board. Refer to Figure 2 for the locations of the various I/O connectors.

P1 Power connector (accepts input from 7 to 15 VDC unregulated power adapter)
J1 36-pin Expansion I/O connector
J2 Power Target Board from power adapter
J3 Port I/O Configuration Connector
J4 DEBUG connector for Debug Adapter interface 
J5 DB-9 connector for UART0 RS232 interface
J6 Analog I/O terminal block
J7 Low pass filter connector
J8 USB Debug Adapter target board power connector
J9, J10 External crystal enable connectors
J11 Power Target Board from USB
J12 Connects external capacitance to P0.7
J13 Connects R14 Potentiometer to P1.7
J14 USB connector for USB interface

Figure 2. C8051F320 Target Board
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6.1.  System Clock Sources
The C8051F320 device installed on the target board features a calibrated programmable internal oscillator which is
enabled as the system clock source on reset. After reset, the internal oscillator operates at a frequency of 1.5 MHz
(±1.5%) by default but may be configured by software to operate at other frequencies. Therefore, in many
applications an external oscillator is not required. However, if you wish to operate the C8051F320 device at a
frequency not available with the internal oscillator, an external crystal may be used. Refer to the C8051F32x
datasheet for more information on configuring the system clock source.
The target board is designed to facilitate the installation of an external crystal. Remove shorting blocks at headers
J9 and J10 and install the crystal at the pads marked Y1. Install a 10 MΩ resistor at R9 and install capacitors at
C14 and C15 using values appropriate for the crystal you select. Refer to the C8051F32x datasheet for more
information on the use of external oscillators.

6.2.  Switches and LEDs
Three switches are provided on the target board. Switch SW1 is connected to the RESET pin of the C8051F320.
Pressing SW1 puts the device into its hardware-reset state. Switch SW2 and SW3 are connected to the
C8051F320’s general purpose I/O (GPIO) pins through headers. Pressing SW2 or SW3 generates a logic low
signal on the port pin. Remove the shorting blocks from the header to disconnect SW2 and SW3 from the port pins.
The port pin signals are also routed to pins on the J1 I/O connector. See Table 1 for the port pins and headers
corresponding to each switch.
Three LEDs are also provided on the target board. The red LED labeled PWR is used to indicate a power
connection to the target board. The green LEDs labeled with port pin names areconnected to the C8051F320’s
GPIO pins through headers. Remove the shorting blocks from the header to disconnect the LEDs from the port pin.
The port pin signals are also routed to pins on the J1 I/O connector. See Table 1 for the port pins and headers
corresponding to each LED.
Also included on the C8051F320 target board is a 10 KΩ Thumb-wheel Rotary Potentiometer, part number R14.
The Potentiometer is connected to the C8051F320’s GPIO pin through a header. Remove the shorting block from
the header to disconnect the Potentiometer from the port pin. The port pin signal is also routed to a pin on the J1 I/
O connector. See Table 1 for the port pin and header corresponding to the Potentiometer.

Table 1. Target Board I/O Descriptions

Description I/O Header
SW1 Reset none
SW2 P2.0 J3[1–2]
SW3 P2.1 J3[3–4]

Green LED P2.2 J3[5–6]
Green LED P2.3 J3[7–8]
Red LED PWR none

Potentiometer R14 J13
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6.3.  Universal Serial Bus (USB) Interface (J14)
A Universal Serial Bus (USB) connector (J14) is provided to facilitate connections to the USB interface on the
C8051F320. Table 2 shows the J14 pin definitions.

6.4.  Expansion I/O Connector (J1)
The 32-pin Expansion I/O connector J1 provides access to all signal pins of the C8051F320 device. Pins for +3 V,
digital ground and the output of an on-board low-pass filter are also available. A small through-hole prototyping
area is also provided. All I/O signals routed to connector J1 are also routed to through-hole connection points
between J1 and the prototyping area (see Figure 2 on page 6). Each connection point is labeled indicating the
signal available at the connection point. See Table 3  for a list of pin descriptions for J1.

6.5.  USB Self-powered Configuration (J2, J11)
The C8051F320 target board can be configured as a self-powered USB device to take power from the USB cable
instead of the ac/dc adapter connected at P1. To configure the target boards as a self-powered USB device,
remove the shorting block from J2 and install on J11. (A shorting block should only be installed on J2 or J11, never
both at the same time.) Install shorting blocks in the following manner:

J2(ON) & J11(OFF) →Target Board is powered from the ac/dc Adapter at P1.
J2(OFF) & J11(ON) →Target Board is powered from the USB connection

Note: When the C8051F320 target board is self-powered from the USB, the Serial Adapter is not powered from the
target board. The Serial Adapter must be powered directly by connecting the ac/dc adapter to the Serial Adapters’
dc power jack. Also, the RS232 Serial Interface (J5) cannot be used when powering the target board from the USB.

Table 2. USB Connector Pin Descriptions

Pin # Description
1 VBUS
2 D-
3 D+
4 GND (Ground)

Table 3. J1 Pin Descriptions

Pin # Description Pin # Description Pin # Description
1 +3 VD (+3.3 VDC) 13 P1.2 25 P2.6
2 PWM Output 14 P1.3 26 P2.7
3 P0.0 15 P1.4 27 P3.0
4 P0.1 16 P1.5 28 /RST (Reset)
5 P0.2 17 P1.6 29 VREGIN
6 P0.3 18 P1.7 30 VDD
7 P0.4 19 P2.0 31 VBUS
8 P0.5 20 P2.1 32 GND (Ground)
9 P0.6 21 P2.2

10 P0.7 22 P2.3
11 P1.0 23 P2.4
12 P1.1 24 P2.5
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6.6.  Target Board DEBUG Interface (J4)
The DEBUG connector (J4) provides access to the DEBUG (C2) pins of the C8051F320. It is used to connect the
Serial Adapter or the USB Debug Adapter to the target board for in-circuit debugging and Flash programming.
Table 4 shows the DEBUG pin definitions.

6.7.  Serial Interface (J5)
A RS232 transceiver circuit and DB-9 (J5) connector are provided on the target board to facilitate serial
connections to UART0 of the C8051F320. The TX, RX, RTS and CTS signals of UART0 may be connected to the
DB-9 connector and transceiver by installing shorting blocks on header J3.

J3[9-10] - Install shorting block to connect UART0 TX (P0.4) to transceiver.
J3[11-12] - Install shorting block to connect UART0 RX (P0.5) to transceiver.
J3[13-14] - Install shorting block to connect UART0 RTS (P2.6) to transceiver.
J3[15-16] - Install shorting block to connect UART0 CTS (P2.7) to transceiver.

6.8.  Analog I/O (J6)
Several of the C8051F320 target device’s port pins are connected to the J6 terminal block. Refer to Table 5 for the
J6 terminal block connections.

6.9.  USB Debug Adapter Target Board Power Connector (J8)
The USB Debug Adapter includes a connection to provide power to the target board. This connection is routed
from J4[10] to J8[1]. Place a shorting block at header J8[2-3] to power the board directly from an ac/dc power
adapter. Place a shorting block at header J8[1-2] to power the board from the USB Debug Adapter. Please note
that the second option is not supported with either the EC1 or EC2 Serial Adapters. 

6.10.  Low-pass Filter (J7)
The C8051F320 target board features a low-pass filter that may be connected to port pin P2.4. Install a shorting
block on J7[1-2] to connect the P2.4 pin of the target device to the low-pass filter input. The output of the low-pass
filter is routed to the PWM signal at J1[2]. The C8051F320 may be programmed to generate a PWM (Pulse-Width
Modulated) waveform which is then input to the low-pass filter to implement a user-controlled PWM digital-to-
analog converter. Refer to Applications Note AN107 - Implementing 16-Bit PWM Using the PCA in the
“documentation” directory on the CD-ROM for a discussion on generating a programmable dc voltage level with a
PWM waveform and low-pass filter.

Table 4. DEBUG Connector Pin Descriptions
Pin # Description

1 +3 VD (+3.3 VDC)
2, 3, 9 GND (Ground)

4 C2D
5 /RST (Reset)
6 P3.0
7 C2CK
8 Not Connected
10 USB Power

Table 5. J6 Terminal Block Pin Descriptions
Pin # Description

1 P2.5 / AIN2.5
2 P2.4 / AIN2.4
3 GND (Ground)
4 P0.7 / Vref (Voltage Reference)
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7.  Schematic   
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DOCUMENT CHANGE LIST

Revision 0.6 to Revision 0.7
Section 1, added USB Debug Adapter and USB Cable.
Section 2, changed name from "Hardware Setup" to "Hardware Setup using an EC2 Serial Adapter".
Section 2, added 2 Notes bullets.
Section 2, removed Note from bottom of page.
Added Section 3, "Hardware Setup using a USB Debug Adapter".
Section 5.4.2, changed step 2 to include new instructions.
Section 7, J4, changed "Serial Adapter" to "Debug Adapter".
Target Board DEBUG Interface Section, added USB Debug Adapter.
DEBUG Connector Pin Descriptions Table, changed pin 4 to C2D.
Changed "jumper" to "header".
EC2 Serial Adapter section, added EC2 to the section title, table title and figure title.
EC2 Serial Adapter section, changed "JTAG" to "DEBUG".
Added "USB Debug Adapter" section.
Section 7, J8, changed "Serial Adapter" to "USB Debug Adapter"
DEBUG Connector Pin Descriptions Table, changed pin 10 to USB Power
USB Debug Adapter Target Board Power Connector (J8) Section, changed "Serial" to "USB Debug"

Revision 0.7 to Revision 0.8
Removed EC2 Serial Adapter from Kit Contents.
Removed Section 2. Hardware Setup using an EC2 Serial Adapter. See RS232 Serial Adapter (EC2) User's 
Guide.
Removed Section 8. EC2 Serial Adapter. See RS232 Serial Adapter (EC2) User's Guide.
Removed Section 9. USB Debug Adapter. See USB Debug Adapter User's Guide.
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CONTACT INFORMATION
Silicon Laboratories Inc.
4635 Boston Lane
Austin, TX 78735
Tel: 1+(512) 416-8500
Fax: 1+(512) 416-9669
Toll Free: 1+(877) 444-3032
Email: MCUinfo@silabs.com
Internet: www.silabs.com

Silicon Laboratories and Silicon Labs are trademarks of Silicon Laboratories Inc.
Other products or brandnames mentioned herein are trademarks or registered trademarks of their respective holders.

The information in this document is believed to be accurate in all respects at the time of publication but is subject to change without notice. 
Silicon Laboratories assumes no responsibility for errors and omissions, and disclaims responsibility for any consequences resulting from 
the use of information included herein. Additionally, Silicon Laboratories assumes no responsibility for the functioning of undescribed features 
or parameters. Silicon Laboratories reserves the right to make changes without further notice. Silicon Laboratories makes no warranty, rep-
resentation or guarantee regarding the suitability of its products for any particular purpose, nor does Silicon Laboratories assume any liability 
arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation conse-
quential or incidental damages. Silicon Laboratories products are not designed, intended, or authorized for use in applications intended to 
support or sustain life, or for any other application in which the failure of the Silicon Laboratories product could create a situation where per-
sonal injury or death may occur. Should Buyer purchase or use Silicon Laboratories products for any such unintended or unauthorized ap-
plication, Buyer shall indemnify and hold Silicon Laboratories harmless against all claims and damages. 



 

 
 

Компания «ЭлектроПласт» предлагает заключение долгосрочных отношений при 
поставках импортных электронных компонентов на взаимовыгодных условиях! 

 
Наши преимущества: 

 Оперативные поставки широкого спектра электронных компонентов отечественного и 
импортного производства напрямую от производителей и с крупнейших мировых 
складов; 

  Поставка более 17-ти миллионов наименований электронных компонентов; 

 Поставка сложных, дефицитных, либо снятых с производства позиций; 

 Оперативные сроки поставки под заказ (от 5 рабочих дней); 

 Экспресс доставка в любую точку России; 

 Техническая поддержка проекта, помощь в подборе аналогов, поставка прототипов; 

 Система менеджмента качества сертифицирована по Международному стандарту ISO 
9001; 

 Лицензия ФСБ на осуществление работ с использованием сведений, составляющих 
государственную тайну; 

 Поставка специализированных компонентов (Xilinx, Altera, Analog Devices, Intersil, 
Interpoint, Microsemi, Aeroflex, Peregrine, Syfer, Eurofarad, Texas Instrument, Miteq, 
Cobham, E2V, MA-COM, Hittite, Mini-Circuits,General Dynamics и др.); 
 

Помимо этого, одним из направлений компании «ЭлектроПласт» является направление 
«Источники питания». Мы предлагаем Вам помощь Конструкторского отдела: 

 Подбор оптимального решения, техническое обоснование при выборе компонента; 

 Подбор аналогов; 

 Консультации по применению компонента; 

 Поставка образцов и прототипов; 

 Техническая поддержка проекта; 

 Защита от снятия компонента с производства. 
 
 
 

 
 

Как с нами связаться 

Телефон: 8 (812) 309 58 32 (многоканальный)  
Факс: 8 (812) 320-02-42  
Электронная почта: org@eplast1.ru  

Адрес: 198099, г. Санкт-Петербург, ул. Калинина, 

дом 2, корпус 4, литера А.  
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