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Simple Sensor Application Kit
The Simple Sensor Application Kit provides a design reference for designers to implement the Dallas 1-Wire® 
bus technology in a Rabbit-based system. These Getting Started instructions and sample applications based 
on four 1-Wire® devices will help users to better understand and implement this communications bus 
system using a Prototyping Board and a RabbitCore module.

Application Kit Contents
• Dynamic C® CD-ROM with complete product documentation and sample programs related to the 

Simple Sensor Application Kit.
• RCM4300 module.

• Prototyping Board with four 1-Wire devices installed.

• 512 MB miniSD™ Card with SD Card adapter

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs).

• USB programming cable with 10-pin header.

• Cat. 5 Ethernet crossover cable.

• 10-pin header to DB9 serial cable.

• Getting Started instructions.

• Plastic and metal standoffs with 4-40 screws and washers.

• A bag of accessory parts for use on the Prototyping Board.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Visit our online Rabbit store at www.rabbit.com/store/ for the latest information on peripherals and acces-
sories that are available for the RCM4300 series of RabbitCore modules.

Step 1 — Install Dynamic C®

Before doing any development, you must install Dynamic C. Insert the CD from the Application Kit in 
your PC’s CD-ROM drive. If the installation does not auto-start, run the setup.exe program in the root 
directory of the Dynamic C CD. Install any other Dynamic C modules after you install Dynamic C.

Run a Sample Program
Once the RCM4300 is connected as described in the preceding pages, start Dynamic C by double-clicking on 
the Dynamic C icon on your desktop or in your Start menu. Select Store Program in Flash on the “Com-
piler” tab in the Dynamic C Options > Project Options menu. Make sure that the Enable Separate 
Instruction & Data Space option is checked. Then click on the “Communications” tab and verify that Use 
USB to Serial Converter is selected to support the USB programming cable. Click OK.

You may have to select the COM port assigned to the USB programming cable on your PC. In Dynamic C, 
select Options > Project Options, then select this COM port on the “Communications” tab, then click OK.

Use the File menu to open the sample program PONG.C, which is in the Dynamic C SAMPLES folder. Press 
function key F9 to compile and run the program.The STDIO window will open on your PC and will display a 
small square bouncing around in a box.

Where Do I Go From Here?
You are now ready to go on to other sample programs and to develop your own applications. Application 
Note AN420, Simple Sensor Application Kit, takes you through loading and using the sample programs 
included with this Application Kit, and describes Rabbit’s software drivers. The RCM4300 User's Manual 
provides complete hardware reference information and describes the software function calls for the 
RCM4300 RabbitCore modules. The FAT File System document on the Dynamic C CD describes the FAT 
file system and discusses the function calls and sample programs available for the Dynamic C implemen-
tation of the FAT file system.

Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Detected."):

• Check that the RCM4300 is powered correctly — the red PWR LED on the Prototyping Board should be lit 
when the RCM4300 is mounted on the Prototyping Board and the AC adapter is plugged in.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the 
PROG connector, not the DIAG connector, is plugged in to the programming port on the RCM4300 with 
the marked (colored) edge of the programming cable towards pin 1 of the programming header.

• Ensure that the RCM4300 module is firmly and correctly installed in its socket on the Prototyping Board.

• If a program compiles and loads, but then loses target communication before you can begin debugging, it is 
possible that your PC cannot handle the default debugging baud rate. Locate the Serial Options dialog in 
the Dynamic C Options > Project Options > Communications menu. Choose a lower debug baud 
rate.

Press <Ctrl-Y> to force Dynamic C to recompile the BIOS. You should receive a Bios compiled 
successfully message once these steps are completed successfully. 

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Technical Bulletin Board and forums at www.rabbit.com/support/bb/ 
and at www.rabbit.com/forums/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your Simple Sensor Application Kit through a distributor or through a Rabbit 
partner, contact the distributor or partner first for technical support.

http://www.zworld.com/support/bb/index.html
http://www.rabbitsemiconductor.com/forums/
http://www.zworld.com/support/questionSubmit.shtml
http://www.rabbit.com/store/


Hardware Connections
Step 1 — Prepare the Prototyping Board
To facilitate handling the Prototyping Board, snap in the 
four standoffs to the four holes at the corners from the 
bottom side of the Prototyping Board as shown in 
Figure 1.

Step 2 — Attach Module to 
Prototyping Board
Turn the RCM4300 module so that the mounting holes 
line up with the corresponding holes on the Prototyping Board. Insert the metal standoffs as shown in 
Figure 2, secure them from the bottom using the 4-40 × 3/16 screws and washers, then insert the module’s 
header J4 on the bottom side into socket RCM4XXX on the Prototyping Board.

NOTE: It is important that you line up the pins on header J4 of the module exactly with socket 
RCM4XXX on the Prototyping Board. The header pins may become bent or damaged if the pin 
alignment is offset, and the module will not work. Permanent electrical damage to the module 
may also result if a misaligned module is powered up.

Press the module’s pins firmly into the Prototyping Board socket—press down in the area above the header 
pins. For additional integrity, you may secure the RCM4300 to the standoffs from the top using the remain-
ing three 4-40 screws and washers.

Step 3 — Connect Programming Cable
The programming cable connects the RCM4300 to the PC running Dynamic C to download programs and to mon-
itor the RCM4300 module during debugging.
Connect the 10-pin connector of the programming cable labeled PROG to header J1 on the RCM4300 as shown 
in Figure 3. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the connector. (Do not 
use the DIAG connector, which is presently not supported by the RCM4300.)
Connect the other end of the programming cable to an available USB port on your PC or workstation.

Figure 2.  Install the RCM4300 Module
on the Prototyping Board

CAUTION: You will sense a soft click 
once you insert the miniSD™ Card 
completely. To remove it, gently press 
the card towards the middle of the 
RCM4300 — you will sense a soft click 
and the card will be ready to be removed. 
Do not attempt to pull the card from the 
socket before pressing it in — otherwise 
the ejection mechanism will get damaged. 
The ejection mechanism is spring-
loaded, and will partially eject the card 
when used correctly.

Figure 1.  Insert Standoffs
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Figure 3.  Connect Programming Cable and Power Supply

Your PC should recognize the new USB hardware, and the LEDs in the shrink-wrapped area of the USB 
programming cable will flash — if you get an error message, you will have to install USB drivers. Drivers 
for Windows XP are available in the Dynamic C Drivers\Rabbit USB Programming Cable\
WinXP_2K folder — double-click DPInst.exe to install the USB drivers. Drivers for other operating 
systems are available online at www.ftdichip.com/Drivers/VCP.htm.

Step 4 — Connect Power
Once all the other connections have been made, you can connect power to the Prototyping Board. 

First, prepare the AC adapter for the country where it will be used by selecting the plug. The RCM4300 
Development Kit presently includes Canada/Japan/U.S., Australia/N.Z., U.K., and European style plugs. 
Snap in the top of the plug assembly into the slot at the top of the AC adapter as shown in Figure 3, then 
press down on the spring-loaded clip below the plug assembly to allow the plug assembly to click into 
place. Release the clip to secure the plug assembly in the AC adapter.

Connect the AC adapter to 3-pin header P1 on the Prototyping Board as shown in Figure 3. The connector 
may be attached either way as long as it is not offset to one side—the center pin of P1 is always connected 
to the positive terminal, and either edge pin is ground.

Plug in the AC adapter. The POWER LED on the Prototyping Board next to the power connector at P1 
should light up. The RCM4300 and the Prototyping Board are now ready to be used.

NOTE: A RESET button is provided on the Prototyping Board to allow a hardware reset without 
disconnecting power.
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Hardware Connections
Step 1 — Prepare the Prototyping Board
To facilitate handling the Prototyping Board, snap in the 
four standoffs to the four holes at the corners from the 
bottom side of the Prototyping Board as shown in 
Figure 1.

Step 2 — Attach Module to 
Prototyping Board
Turn the RCM4300 module so that the mounting holes 
line up with the corresponding holes on the Prototyping Board. Insert the metal standoffs as shown in 
Figure 2, secure them from the bottom using the 4-40 × 3/16 screws and washers, then insert the module’s 
header J4 on the bottom side into socket RCM4XXX on the Prototyping Board.

NOTE: It is important that you line up the pins on header J4 of the module exactly with socket 
RCM4XXX on the Prototyping Board. The header pins may become bent or damaged if the pin 
alignment is offset, and the module will not work. Permanent electrical damage to the module 
may also result if a misaligned module is powered up.

Press the module’s pins firmly into the Prototyping Board socket—press down in the area above the header 
pins. For additional integrity, you may secure the RCM4300 to the standoffs from the top using the remain-
ing three 4-40 screws and washers.

Step 3 — Connect Programming Cable
The programming cable connects the RCM4300 to the PC running Dynamic C to download programs and to mon-
itor the RCM4300 module during debugging.
Connect the 10-pin connector of the programming cable labeled PROG to header J1 on the RCM4300 as shown 
in Figure 3. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the connector. (Do not 
use the DIAG connector, which is presently not supported by the RCM4300.)
Connect the other end of the programming cable to an available USB port on your PC or workstation.

Figure 2.  Install the RCM4300 Module
on the Prototyping Board

CAUTION: You will sense a soft click 
once you insert the miniSD™ Card 
completely. To remove it, gently press 
the card towards the middle of the 
RCM4300 — you will sense a soft click 
and the card will be ready to be removed. 
Do not attempt to pull the card from the 
socket before pressing it in — otherwise 
the ejection mechanism will get damaged. 
The ejection mechanism is spring-
loaded, and will partially eject the card 
when used correctly.

Figure 1.  Insert Standoffs
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Figure 3.  Connect Programming Cable and Power Supply

Your PC should recognize the new USB hardware, and the LEDs in the shrink-wrapped area of the USB 
programming cable will flash — if you get an error message, you will have to install USB drivers. Drivers 
for Windows XP are available in the Dynamic C Drivers\Rabbit USB Programming Cable\
WinXP_2K folder — double-click DPInst.exe to install the USB drivers. Drivers for other operating 
systems are available online at www.ftdichip.com/Drivers/VCP.htm.

Step 4 — Connect Power
Once all the other connections have been made, you can connect power to the Prototyping Board. 

First, prepare the AC adapter for the country where it will be used by selecting the plug. The RCM4300 
Development Kit presently includes Canada/Japan/U.S., Australia/N.Z., U.K., and European style plugs. 
Snap in the top of the plug assembly into the slot at the top of the AC adapter as shown in Figure 3, then 
press down on the spring-loaded clip below the plug assembly to allow the plug assembly to click into 
place. Release the clip to secure the plug assembly in the AC adapter.

Connect the AC adapter to 3-pin header P1 on the Prototyping Board as shown in Figure 3. The connector 
may be attached either way as long as it is not offset to one side—the center pin of P1 is always connected 
to the positive terminal, and either edge pin is ground.

Plug in the AC adapter. The POWER LED on the Prototyping Board next to the power connector at P1 
should light up. The RCM4300 and the Prototyping Board are now ready to be used.

NOTE: A RESET button is provided on the Prototyping Board to allow a hardware reset without 
disconnecting power.

��

��
��

���

��

���
�

	�

�
�

�
�



��

�

�

������

�
�

�



�
�

�
�

�
�

�
�� �
�

�
��

���

���

�
��

�
��

	�

���

��
��

����
�
�
�


��

�
��

���

�
��

�
�
� 	���

�����

�
�
�

�
�
�

���

�
��

�
��

���

�
��

�
��

�
��

�
�

���
���

���

�
�

�
��

�
��

���

�
� �

�

�
�

��� ���

��

�
�


�
��

�
��

�
��

�
��

�
�


�
��

���

�
��

��������������	����

���

�
��

�
�

����

����

����

������

�
�

���

��
�

�
��

��
�

���
���

���

���

��


���

����

����

�
� �



�
�

�
�

�
�

���
���

�
�

�
��

�
��

�
��

�
��

�
��

�
��

�
��

�
�


�
��

���
���

��	������


�
�

�
�

�

������� !�"�#���$%
&' �$"�"()�&'"�� !�"

�'(*�*!+,�&'"��*!(#��

�
��������

��	������


�����
����	
��������	 ��

��!�$�-
�-,�

.�
�
�
�


�
�
�*
�$
"

�
�
/
0

�
�1
0

�
��
����
�
�����

�
�
/
0

��

http://www.ftdichip.com/Drivers/VCP.htm


Rabbit and Dynamic C are registered trademarks of Digi International Inc.
1-Wire is a registered trademark of Dallas Semiconductor Corp.

020–0154 • 090131–A

Simple Sensor Application Kit
The Simple Sensor Application Kit provides a design reference for designers to implement the Dallas 1-Wire® 
bus technology in a Rabbit-based system. These Getting Started instructions and sample applications based 
on four 1-Wire® devices will help users to better understand and implement this communications bus 
system using a Prototyping Board and a RabbitCore module.

Application Kit Contents
• Dynamic C® CD-ROM with complete product documentation and sample programs related to the 

Simple Sensor Application Kit.
• RCM4300 module.

• Prototyping Board with four 1-Wire devices installed.

• 512 MB miniSD™ Card with SD Card adapter

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs).

• USB programming cable with 10-pin header.

• Cat. 5 Ethernet crossover cable.

• 10-pin header to DB9 serial cable.

• Getting Started instructions.

• Plastic and metal standoffs with 4-40 screws and washers.

• A bag of accessory parts for use on the Prototyping Board.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Visit our online Rabbit store at www.rabbit.com/store/ for the latest information on peripherals and acces-
sories that are available for the RCM4300 series of RabbitCore modules.

Step 1 — Install Dynamic C®

Before doing any development, you must install Dynamic C. Insert the CD from the Application Kit in 
your PC’s CD-ROM drive. If the installation does not auto-start, run the setup.exe program in the root 
directory of the Dynamic C CD. Install any other Dynamic C modules after you install Dynamic C.

Run a Sample Program
Once the RCM4300 is connected as described in the preceding pages, start Dynamic C by double-clicking on 
the Dynamic C icon on your desktop or in your Start menu. Select Store Program in Flash on the “Com-
piler” tab in the Dynamic C Options > Project Options menu. Make sure that the Enable Separate 
Instruction & Data Space option is checked. Then click on the “Communications” tab and verify that Use 
USB to Serial Converter is selected to support the USB programming cable. Click OK.

You may have to select the COM port assigned to the USB programming cable on your PC. In Dynamic C, 
select Options > Project Options, then select this COM port on the “Communications” tab, then click OK.

Use the File menu to open the sample program PONG.C, which is in the Dynamic C SAMPLES folder. Press 
function key F9 to compile and run the program.The STDIO window will open on your PC and will display a 
small square bouncing around in a box.

Where Do I Go From Here?
You are now ready to go on to other sample programs and to develop your own applications. Application 
Note AN420, Simple Sensor Application Kit, takes you through loading and using the sample programs 
included with this Application Kit, and describes Rabbit’s software drivers. The RCM4300 User's Manual 
provides complete hardware reference information and describes the software function calls for the 
RCM4300 RabbitCore modules. The FAT File System document on the Dynamic C CD describes the FAT 
file system and discusses the function calls and sample programs available for the Dynamic C implemen-
tation of the FAT file system.

Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Detected."):

• Check that the RCM4300 is powered correctly — the red PWR LED on the Prototyping Board should be lit 
when the RCM4300 is mounted on the Prototyping Board and the AC adapter is plugged in.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the 
PROG connector, not the DIAG connector, is plugged in to the programming port on the RCM4300 with 
the marked (colored) edge of the programming cable towards pin 1 of the programming header.

• Ensure that the RCM4300 module is firmly and correctly installed in its socket on the Prototyping Board.

• If a program compiles and loads, but then loses target communication before you can begin debugging, it is 
possible that your PC cannot handle the default debugging baud rate. Locate the Serial Options dialog in 
the Dynamic C Options > Project Options > Communications menu. Choose a lower debug baud 
rate.

Press <Ctrl-Y> to force Dynamic C to recompile the BIOS. You should receive a Bios compiled 
successfully message once these steps are completed successfully. 

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Technical Bulletin Board and forums at www.rabbit.com/support/bb/ 
and at www.rabbit.com/forums/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your Simple Sensor Application Kit through a distributor or through a Rabbit 
partner, contact the distributor or partner first for technical support.

http://www.zworld.com/support/bb/index.html
http://www.rabbitsemiconductor.com/forums/
http://www.zworld.com/support/questionSubmit.shtml
http://www.rabbit.com/store/


 

 
 

Компания «ЭлектроПласт» предлагает заключение долгосрочных отношений при 
поставках импортных электронных компонентов на взаимовыгодных условиях! 

 
Наши преимущества: 

 Оперативные поставки широкого спектра электронных компонентов отечественного и 
импортного производства напрямую от производителей и с крупнейших мировых 
складов; 

  Поставка более 17-ти миллионов наименований электронных компонентов; 

 Поставка сложных, дефицитных, либо снятых с производства позиций; 

 Оперативные сроки поставки под заказ (от 5 рабочих дней); 

 Экспресс доставка в любую точку России; 

 Техническая поддержка проекта, помощь в подборе аналогов, поставка прототипов; 

 Система менеджмента качества сертифицирована по Международному стандарту ISO 
9001; 

 Лицензия ФСБ на осуществление работ с использованием сведений, составляющих 
государственную тайну; 

 Поставка специализированных компонентов (Xilinx, Altera, Analog Devices, Intersil, 
Interpoint, Microsemi, Aeroflex, Peregrine, Syfer, Eurofarad, Texas Instrument, Miteq, 
Cobham, E2V, MA-COM, Hittite, Mini-Circuits,General Dynamics и др.); 
 

Помимо этого, одним из направлений компании «ЭлектроПласт» является направление 
«Источники питания». Мы предлагаем Вам помощь Конструкторского отдела: 

 Подбор оптимального решения, техническое обоснование при выборе компонента; 

 Подбор аналогов; 

 Консультации по применению компонента; 

 Поставка образцов и прототипов; 

 Техническая поддержка проекта; 

 Защита от снятия компонента с производства. 
 
 
 

 
 

Как с нами связаться 

Телефон: 8 (812) 309 58 32 (многоканальный)  
Факс: 8 (812) 320-02-42  
Электронная почта: org@eplast1.ru  

Адрес: 198099, г. Санкт-Петербург, ул. Калинина, 

дом 2, корпус 4, литера А.  
 

mailto:org@eplast1.ru

