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bq2650X Single-Cell Battery Fuel Gauge Tester and
Programmer

PMP Portable Power

ABSTRACT

The Texas Instruments bq2650X Tester Kit tests and programs bq26500 and bg26501
single-cell Li-ion and Li-polymer battery gas gauge devices. The kit includes a bq2650X
Test and Program PC interface board for gas gauge testing, one RS-232 cable, a CD
ROM including Windows ™-based PC software, and support documentation.
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1 Introduction

The Texas Instruments bq2650X Tester Kit tests and programs bq26500 and bq26501 single-
cell Li-ion and Li-polymer battery gas gauge devices. The kit includes a bq2650X Test and
Program PC interface board for gas gauge testing, one RS-232 cable, a CD ROM including
Windows™-based PC software, and support documentation. This kit tests the electronic
modules prior to pack installation.

1.1 Features

e Complete test and program system for the bq26500 and bg26501 battery gas gauge

e PC software and interface board for production test

e Software allows EEPROM programming and production data logging.

1.2 Kit Contents

1. HPAO048 PC interface test board (bq2650X Test and Program) for RS-232
2. CD ROM including Windows-based PC software and support documentation
3. RS-232 cable

2 bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer
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1.3 Ordering Information
KIT PART NUMBER | PC INTERFACE CHEMISTRY | PACK VOLTAGE
BOARD
bq2650XTester-Kit | RS-232 Li-ion 26Vto45V

2 Installation and Setup

2.1 Minimum System Requirements

Operating system: Windows 98, 2000, or XP

Video: Super VGA — 1024 x 768 minimum resolution

RAM: 16M bytes
Hard drive space: 5M bytes
RS-232 port: 1 available

2.2 Final Test Board Specifications

+9Vto +12 V DC minimum 1 A
Analog inputs: £ 6 V
Digital inputs: 0to + 5V

Note: Values greater than these limits entered into the final test system connections to the

hardware may cause permanent damage to the final test board.

2.3 Interface Connections

The bg2650X Test and Program system requires the host PC to be connected to the final test
board using RS-232. The power supply is connected to the connector on the side of the final test
board, as shown in Figure 1. The test head (test fixture) can be constructed following the
interface connection table in section 2.3.1 using a schematic and assembly drawing for the
module to be tested. It is recommended that test head cables not exceed 12 inches in length.
Spring-loaded test pins are recommended for module testing. Connection of test head to module
requires precision contacts to ensure good electrical contact.

bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer 3
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Test Fixure
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Figure 1. bq2650X Test and Program Board

2.3.1 Test Head Fixture Interface
The test head interface for the bq2650X Test and Program board requires a Molex female 6-pin

connector #22-01-3067 with crimp terminals (tin) #08-50-0114. Table 1 contains data pertaining
to the test points.

Table 1. Test Points

Molex Color Wire Gauge

Connector Description Code Insulated
Pin (12 inches)

1 Batt - Black 22 AWG

2 HDQ Brown 22 AWG

3 N/C N/A N/A

4 GPIO White 22 AWG

5 Pack+ Red 22 AWG

6 Pack - Black 22 AWG

2.3.2 Computer to Test System Interface

Connect the bg2650X Test and Program board to the computer communication port using the
RS-232 cable.

2.4 System Power Up

After all connections are made, the final test board is powered with a power supply that provides
+9V to +12 V DC (minimum 1 A) into the jack located on the side of the test board. Visually
verify the green LED labeled D11 is ON. Power can also be applied using an external power
supply between +9 V to +12 V DC (minimum 1 A).

4 bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer
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3 Software Contents and Installation

3.1 Software Contents

The bg2650X Tester Kit contains all software on a CD ROM as follows:

1.

2.

3.
4.

Documentation

a. bg2650X User’s Guide (SLUU185A)
b. bg26501 Data Sheet

c. HPA048 Schematic

d. HPAO048 Top Assembly

e. HPAO048 Bill of Materials

f. PIC Program V402 hex

Install Executable Program

a. CAB Files

b. setup.exe

c. bqg2650X.gg Default EEPROM File
Visual Basic Source Code

ReadMefFirst.txt File

3.2 Software Installation

Use the following steps to install the bq2650X Test and Program software:

1.

Insert the CD ROM into a CD ROM drive.

2. Select the CD ROM drive using My Computer or File Manager.
3. Select the ReadMeFirst.txt File.
4. The setup program installs a Windows application group.

4 Operation

The bg2650X Test and Program board verifies assembly functions for the RBI pin, Sense
Resistor, and Battery pin, while also programming EEPROM data.

The bg2650X reference module (EVM HPAO033) can be used to test the integrity of the Device
Test Port prior to connecting the test head fixture. Perform the reference test anytime the device
under test (DUT) port is in question.

bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer 5
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Perform module tests before pack tests so that complete calibration and functional testing is
accomplished prior to pack assembly. The bq2650X test board is for module test only. Do not

attempt to use for pack test.

4.1 Starting the Program

Run the program from the Start|Programs|Texas Instruments|bq2650X menu sequence. If the
bg2650X Test and Program board is connected to the RS-232 port, the program loads and
displays the initial Test Menu Screen shown in Figure 2. The communication port can be
changed by selecting the port under the Options menu.

b| bgZ6500 Battery Test System ;IE'EI

Eile Options Help

High-Periormance REAL WORLD SIGNAL PROCESSING.
L S
- bq2650X Test System
TEST Pass / Fail Production Data Results
BAT Pin Serial Number
Sense Resistor Total Pass
Test Menu EEPRCM Total Fail
RBI Pin Total Yield

Load
EEPROM

Engineering

REat WORLD SIGWAL PROGESSINE" <8 s S TRbASTS
| tos2i/2002 | 1D04EM

| Communication Status | | |

Figure 2. Test Menu Screen

4.2 |Initialization
This section describes the settings that must be made before testing the bg2650X.

4.2.1 Load EEPROM

Click on the Load EEPROM selection. The Load EEPROM screen appears as shown in Figure
3. From the menu bar, select File > Open Gas Gauge EEPROM Constants. Find the directory

where the bq2650X.gg file is located, and select the file. Once you have selected the
configuration file, click on Test Menu, and skip to section 4.4 to begin testing.

6 bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer
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Note: Do not attempt to change the configuration data while in the Load EEPROM menu

selection. See section 4.3.2 to modify and save configuration files.

il
File Options Help
™
High-Performance REAL WoORLD SIGNAL PROCESSING
ﬂ Analog
- bq2630X Test System
MName Walue ‘ LInit Addr ‘ Data | Addr ‘ Data
Initizl LD mah 0x76 0x78
EDYF Threshold m' Ox77 0x7C
ED%1 Threshold my 075 07D
Initiadl Standby Lo ma, 0x79 0=7E
Digtal Fiter Threshald e 07 A 0<7F
Self Discharge Rate (v) Seldary
Taper Current ma,
Load Pack Configuration hesx Sense Resistor = IZD.DD mhim
EEPROM Customer ID #3 hex
Dsg Rate Comp Gain W C-rate
Dsg Rate Comp Thresh mah Code
N N Tempersture Comp Gain Sl DEC
Tempetature Comp Offset 5T
' . Y S ——
BEal WoRLD SIGWAL PROBESSINGE T s SIS
| Commurication Status | [ | [ 1m0 | gtaM 4

Figure 3. Load EEPROM Screen

4.3 Engineering

4.3.1

The Engineering section is a password-protected menu providing the opportunity to change the
configuration file or enable/disable specific tests. This menu is for engineering debugging in a
production test environment.

Password

Selecting the Engineering option brings up a password entry selection. Enter bmrq in the
password field; the User ID field is left blank. It is recommended that the password be changed
once the system is ready for production test. Use the menu bar, and select Options to change
the password.

If the password is modified and the new password is not known, the bq2650X.exe must be
reloaded where the password is now the default.

bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer
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4.3.2 Test Selection Options

The Engineering screen is now present as shown in Figure 4. In this section, use the menu bar
to select File > Open Gas Gauge EEPROM Constants. Find the directory where the
bq2650X.gg file is located, and select the file. Configuration data can be modified and saved to a
file but only in the Engineering menu selection. Using the mouse, click on the data to modify,
and after updating the field, press the Enter key. Select Save As from the File menu, and enter a
file name to save the new configuration file. Once the configuration file has been selected or
saved, click on Test Menu, and go to section 4.4 to begin testing modules.

=101 x|
File Options Help
High-Performance REAL WORLD SIGNAL PROCESSING.

P ey bq2650X Test System

Marne “Walue | Lnit Addr ‘ Data ‘ Addr | Diata
Initial LD mah 0x76 0x78
EDYF Threshold m 07y Ox7C
ED%1 Threshald m 0x78 0x7D
Initial Standly Load ma, 073 0x7E
Digiital Filter Threshold uv Lt 0x7F
Self Discharge Rate (y) Folclay
Customer| 1o Cyrrent ma,
Load H9 Pack Configuration hesx Sense Resistar = |2D.DD mOhm
EEPROM Customer ID #3 hex
H =g Rate Comp Gain YelC-rate
Dsg Rate Comp Thresh ma&h Code
[~ |Tempersture Comp Gain WLMDAC Test Selections
- Temperature Comp Offset 9T ¥ BAT Fin Test

¥ Sense Resistor Test

Fead EEPROM wiite all EEFR DR ¥ EEFROM Programming
¥ REl Pin Test

¥ Display Engineering Urits

REAL WORLD SIGWAL PROBESSINE" {?}m’?ﬁmumﬁ
| Commurnication Status | | | | fof22/2003 | 10:224M 4

Figure 4. Engineering Screen

4.4 Production Test

At this time, power to the bq2650X Test and Program board is on, and testing can begin. Figure
5 displays an example of the status and results when testing a passing module.

bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer
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File ©ptions Help
High-Performance REAL WORLD SIGNAL PROCESSING.

ﬂ Analog
o~ bq26350X Test System
TEST Fass f Fail Production Data Results
EAT Pin PASS Serial Number 1
Sense Resistor PASS Total Pass 1
EEPROM PASS Total Fail
REI Pin PASS Total Yield 100%
Load PASS
EEPROM
START STOP
REAL WORLD SIGWAL PROBESSIME" {@‘M‘@Mummmg
| Comrurication Status OK. | [ | | 1o/22:2003 | G38aM

Figure 5. Test Menu Results Screen

4.4.1 Start and Stop Functions

The Start icon on the Test Menu screen is used to begin testing the module. The test results
appear on the screen after each test selected with either a PASS or FAIL indication. The Stop
icon immediately stops the test, and the Results section will not be updated.

4.4.2 Display Definitions

Completed status of the module under test is indicated with a green PASS or red FAIL condition.
Results: Displays and keeps running totals of modules tested.

1. Serial Number: Displays the last serial number tested.

Total Pass: Displays the total number of good modules.

Total Fail: Displays the total number of rejected modules.

W N

Total Yield: Displays the total good divided by the total tested on a percentage basis.

bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer 9
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4.5 Pass/Fail Status

4.5.1 Data Logging

Data is logged on the computer monitor and can also be placed in a lot summary data file. After
all testing has been completed, the results can be stored in a . SUMMARY file. From the Menu
bar, select File > Log Test Summary. A prompt asks for a file name; at this time, select a
directory where the test summary data log file will be placed. The lot summary data log file is
recommended during production test to keep information stored on a by-lot basis.

Note: The program does not log the data into a .SUMMARY file until all testing is complete.

4.5.2 Example Data Log .SUMMARY File

Texas Instruments bq2650X Gas Gauge Production Test Summary
bq2650X Version 1.0.0
9/24/2003 4:14:02 PM

[Production Test Summary]
Serial Number from 1 to 4

Total Pass=3
Total Fail=1
Total Tested=4
Yield=75%

[Module Pass/Fail Summary]

Pass =3

Fail BAT Pin=0

Fail Sense Resistor=1
Fail EE Verification=0
Fail RBI Pin=0

5 Test Descriptions for bq2650X

5.1 Theory of Operation for bq2650X

This section contains a brief description of the bq2650X Module Test procedures. Power supply

voltage to Pack + (V) equals 3.8 V +/-20 mV.

5.1.1 BAT Pin Test

Verify the VOLTH and VOLTL registers contain the reported battery voltage measured on the
BAT pin. It is important to wait for the device to complete a full conversion, approximately 1.8
seconds, before taking a measurement. The program is set up to read back 3.8 V +/- 100 mV

from the specified registers.

10 bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer
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5.1.2 Sense Resistor Test

Verify that the sense resistor is functioning properly with the following procedure:

1.

Read Discharge Counts Register (DCR) from address registers 0x6A and 0x6B, record
the values, and store in DCR counts “Original.”

Source current on Pack - to generate DCR counts.

Read DCR from address registers 0x6A and 0x6B, record the values, and store in DCR
counts “Final.”

Compare absolute DCR counts “Final” minus DCR counts “Original,” and check for a
specified range of valid DCR counts for the sense resistor value used.

5.1.3 EEPROM Programming

1.

Enable the programming mode by writing data OxDD to the EE_EN register (addr OX6E).

Latch data by performing a Write, then Read operation from the .gg configuration file.

2
3. Apply 21 V to GPIO pin to program latched EEPROM data into the gas gauge.
4.
5

Read verify from EEPROM registers for values equal to the .gg configuration file.

Disable the programming mode by writing data 0x00 to the EE_EN register (addr Ox6E).

5.1.4 RBI Pin Test

Verify that the RBI pin provides backup power to the internal registers when V. drops below the
power-on-reset (POR) voltage. The test procedure is as follows:

1.

© ® N o a &~ 0N

Write data OxAS to At Rate register 0x02.

Write data Ox5A to At Rate register 0x03.

Enable WRTNAC bit in Mode register 0x01.

Write OxA9 to Device Control register 0x00, which clears the POR bit.

Read Control Register 0x00 until the register has cleared.

Generate POR condition by turning Pack+ OFF for 200 ms.

Turn Pack+ ON, and read Mode register 0x01 to verify the POR bit has been set.
Read and store the values from NAC registers 0x0C and 0x0D.

Verify NAC register values retained the data written in the foregoing steps 1 and 2.

bq2650X Single-Cell Battery Fuel Gauge Tester and Programmer 11
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KomnaHus ((3J'IeKTpO|_|J'|aCT» npeanaraeT 3akKn4vyeHmne onrocpoYHbIX OTHOLLIEHUN npu
NOoCTaBKaxX MMMNOPTHbIX 3NTEKTPOHHbIX KOMMOHEHTOB Ha B3aMMOBbLIFO4HbIX yCJ'IOBI/lFlX!

Hawwn npeumyuiectsa:

e OnepaTuBHbIE NOCTABKM LUMPOKOrO CMeKTpa 3NeKTPOHHbIX KOMMNOHEHTOB OTEYECTBEHHOIO U
MMMOPTHOrO NPON3BOACTBA HANPAMYO OT MPOM3BOAMTENEN U C KPYNMHENLLNX MUPOBbLIX
CKNaaos.;

MocTaBka 6onee 17-TM MUNIIMOHOB HAMMEHOBAHWUIN 3NEKTPOHHbLIX KOMMNOHEHTOB;

MocTaBka CNoXHbIX, AeULNTHBIX, MMOO CHATLIX C MPOM3BOACTBA NO3ULIUIA;

OnepaTtunBHbIE CPOKM NOCTABKM Nof 3aka3 (0T 5 pabounx gHewn);

OKcnpecc goctaska B Nnobyto Touky Poccuu;

TexHnyeckas nogaepkka npoekTa, NomMoLLlb B nogdope aHanoros, NocTaBka NPOTOTUMOB;

Cuctema MeHeXMeHTa KavyecTBa cepTuduumnposaHa no MexayHapogHomy ctaHgapTty 1ISO

9001;

o JlnueHausa ®CH Ha ocyulecTBneHne paboT ¢ NCNONb30BaHWEM CBEOEHUIN, COCTABAOLLINX
rocygapCTBEHHYIO TalHy;

o [locTaBka cneumnanmampoBaHHbIX KOMNoHeHToB (Xilinx, Altera, Analog Devices, Intersil,
Interpoint, Microsemi, Aeroflex, Peregrine, Syfer, Eurofarad, Texas Instrument, Miteq,
Cobham, E2V, MA-COM, Hittite, Mini-Circuits,General Dynamics v gp.);

MoMMMO 3TOro, O4HMM M3 HanpaBnNeHU koMnaHum «AnekTpollnacT» ABNseTca HanpaBneHne

«UcTouHmkn nutaHua». Mel npeanaraem Bam nomoub KoHCTpyKTOpCKOro otaena:

e [logGop onTuManeHOro peleHus, TexHn4eckoe 060CHOBaHME Npu BbIOOpPE KOMMOHEHTA;
Monbop aHanoros.;
KoHcynbTaumm no NpUMEHEHMIO KOMMOHEHTA;
MocTaBka 06pa3yoB M NPOTOTUMNOB;
TexHn4veckasn noaaepka npoekTa;
3awmTa OT CHATMSA KOMMOHEHTA C NPON3BOACTBA.

Kak c Hamu cBfizaTbCcA

TenedoH: 8 (812) 309 58 32 (MHOrokaHanbHbIN)
Pakc: 8 (812) 320-02-42

OnekTpoHHas nouTta: org@eplastl.ru

Aapec: 198099, r. Cankt-INeTepbypr, yn. KannHuHa,
Oom 2, kopnyc 4, nutepa A.
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