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Preface

INTRODUCTION

This chapter contains general information that will be useful to know before using
MPLAB® X IDE. Items discussed include:

Document Layout
Conventions Used
Recommended Reading

DOCUMENT LAYOUT

This document describes how to use the MPLAB X IDE. The layout of the manual is as
follows:

Chapter 1. “What is MPLAB X IDE?” — an overview of what the MPLAB X IDE is
and where to find help.

Chapter 2. “Before You Begin” — describes how to install USB drivers for the
hardware tools and language toolsuites for compiling/assembling code.

Chapter 3. “Tutorial” — provides step-by-step descriptions of features for using
MPLAB X IDE.

Chapter 4. “Basic Tasks” — describes how to use the basic features of MPLAB X
IDE. It is similar to the Tutorial chapter but with more detail.

Chapter 5. “Additional Tasks” — describes how to use additional features of
MPLAB X IDE, e.g., importing MPLAB IDE v8 projects or using the stopwatch.
Chapter 6. “Advanced Tasks” — describes how to use the advanced features of
MPLAB X IDE, e.g., working with multiple projects and project configurations.
Chapter 9. “Troubleshooting” — discusses troubleshooting techniques.
Chapter 10. “MPLAB X IDE vs. MPLAB IDE v8” — explains the major feature,
menu, and tool support differences between MPLAB X IDE and MPLAB IDE v8.
Chapter 11. “Desktop Reference” — provides a reference to MPLAB X IDE
desktop items, including menus, toolbars, and the status bar.

Chapter 12. “MPLAB X IDE Windows and Dialogs” — references NetBeans™
windows and dialogs and discusses the windows and dialogs that are unique to
MPLAB X IDE.

Chapter 8. “Project Files and Folders” — explains the folder structure and
locations of project files.

Appendix A. “Configuration Settings Summary” — shows how to set Configu-
ration bits in code for supported language tools. This is required in MPLAB X IDE
as the Configurations Settings window only temporarily sets the bits for debug.

© 2011-2014 Microchip Technology Inc. DS50002027C-page 7
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CONVENTIONS USED

The following conventions may appear in this documentation:

DOCUMENTATION CONVENTIONS

dialog, or an individual menu
item

Description Represents Examples
Arial font:
Italic Referenced books MPLAB® IDE User’s Guide
Emphasized text ...is the only compiler...
Initial caps A window the Output window
A dialog the Settings dialog
A menu selection select Enable Programmer
Quotes A field name in a window or | “Save project before build”

Underlined, italic with right A path in text File>Save
angle bracket between text

Right angle bracket between | A path in a table cell File>Save
text

Bold characters A dialog button Click OK

A tab

Click the Power tab

Text in angle brackets < >

A key on the keyboard

Press <Enter>, <F1>

Courier New font:

Plain Sample source code #define START
Filenames autoexec.bat
File paths c:\mccl8\h
Keywords _asm, _endasm, static
Command-line options -Opa+, -Opa-
Bit values 0, 1
Constants OXFF, 'A’
Italic A variable argument file.o, where file can be

any valid filename

Square brackets [ ]

Optional arguments

mpasmwin [optiong]
file [options]

Curly brackets and pipe
character: {| }

Choice of mutually exclusive
arguments; an OR selection

errorlevel {0]|1}

Ellipses...

Replaces repeated text

var name [,
var name...]

Represents code supplied by
user

void main (void)
{
}

DS50002027C-page 8
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RECOMMENDED READING

This user’s guide describes how to use MPLAB X IDE. Other useful documents are
listed below. The following Microchip documents are available and recommended as
supplemental reference resources.

Readme for MPLAB IDE

For the latest information on using MPLAB X IDE, read the release notes under the
“Release Notes and Support Documentation” heading on the Start page. The release
notes contain update information and known issues that may not be included in this
user’s guide.

Readme Files

For the latest information on using other tools, read the tool-specific Readme files in
the Readmes subdirectory of the MPLAB X IDE installation directory. The Readme files
contain update information and known issues that may not be included in this user’s
guide.

Online Help Files

Comprehensive help files are available for MPLAB X IDE, MPLAB Editor and MPLAB
SIM simulator. Tutorials, functional descriptions and reference material are included.
Device Data Sheets and Family Reference Manuals

See the Microchip web site, http://www.microchip.com, for complete and updated ver-
sions of PIC® MCU and dsPIC® DSC data sheets and related device family reference
manuals.

© 2011-2014 Microchip Technology Inc. DS50002027C-page 9
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Chapter 1. What is MPLAB X IDE?

1.1 INTRODUCTION

MPLAB® X IDE is a software program that is used to develop applications for Microchip
microcontrollers and digital signal controllers. (Experienced embedded-systems
designers may want to skip to the next chapter.)

This development tool is called an Integrated Development Environment, or IDE,
because it provides a single integrated “environment” to develop code for embedded
microcontrollers.

This chapter describes the development of an embedded system and briefly explains
how MPLAB X IDE from Microchip is used in the process.

Topics discussed here include the following:

* An Overview of Embedded Systems
» The Development Cycle

* Project Manager

» Language Tools

» Target Debugging

* Device Programming

* Components of MPLAB X IDE

+ MPLAB X IDE Online Help

» Other MPLAB X IDE Documentation
* Web Site

+ MPLAB X IDE Updates

© 2011-2014 Microchip Technology Inc. DS50002027C-page 11
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1.2 AN OVERVIEW OF EMBEDDED SYSTEMS

An embedded system is typically a design that uses the power of a small microcontrol-
ler, like the Microchip PIC® microcontroller (MCU) or dsPIC® digital signal controller
(DSC). These microcontrollers combine a microprocessor unit (like the CPU in a per-
sonal computer) with some additional circuits called peripherals, plus some additional
circuits on the same chip to make a small control module requiring few other external
devices. This single device can then be embedded into other electronic and
mechanical devices for low-cost digital control.

1.2.1 Differences Between an Embedded Controller and a Personal
Computer

The main difference between an embedded controller and a personal computer is that
the embedded controller is dedicated to one specific task or set of tasks. A personal
computer is designed to run many different types of programs and to connect to many
different external devices. An embedded controller has a single program and, as a
result, can be made cheaply to include just enough computing power and hardware to
perform that dedicated task.

A personal computer has a relatively expensive generalized central processing unit
(CPU) at its heart with many other external devices (memory, disk drives, video con-
trollers, network interface circuits, etc.). An embedded system has a low-cost micro-
controller unit (MCU) for its intelligence, with many peripheral circuits on the same chip,
and with relatively few external devices.

Often, an embedded system is an invisible part, or sub-module of another product,
such as a cordless drill, refrigerator or garage door opener. The controller in these
products does a tiny portion of the function of the whole device. The controller adds
low-cost intelligence to some of the critical sub-systems in these devices.

An example of an embedded system is a smoke detector. Its function is to evaluate sig-
nals from a sensor and sound an alarm if the signals indicate the presence of smoke.
A small program in the smoke detector either runs in an infinite loop, sampling the sig-
nal from the smoke sensor, or lies dormant in a low-power “Sleep” mode, being awak-
ened by a signal from the sensor. The program then sounds the alarm. The program
would possibly have a few other functions, such as a user test function, and a low
battery alert.

While a personal computer with a sensor and audio output could be programmed to do
the same function, it would not be a cost-effective solution (nor would it run on a
nine-volt battery, unattended for years!). Embedded designs use inexpensive micro-
controllers to put intelligence into the everyday things in our environment, such as
smoke detectors, cameras, cell phones, appliances, automobiles, smart cards and
security systems.

1.2.2 Components of a Microcontroller

The PIC MCU has on-chip program memory (Figure 1-1) for the firmware, or coded
instructions, to run a program (Figure 1-2). A Program Counter (PC) is used to address
program memory, including Reset and interrupt addresses. A hardware stack is used
with call and return instructions in code, so it works with, but is not part of, program
memory. Device data sheets describe the details of program memory operation,
vectors and the stack.

DS50002027C-page 12
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FIGURE 1-1: PIC® MCU DATA SHEET — PROGRAM MEMORY AND STACK

| PC<12:0> |
CALL, RETURN 13
RETFIE, RETLW

Stack Level 1

Stack Level 2
]
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Reset Vector 0000h
]
. <——
Interrupt Vector 0004h
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Access 0-FFFh
1FFFh
FIGURE 1-2: PIC® MCU DATA SHEET — INSTRUCTIONS (EXCERPT)
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The microcontroller also has data or “file register” memory. This memory consists of
Special Function Registers (SFRs) and General Purpose Registers (GPRs) as shown
in Figure 1-4. SFRs are registers used by the CPU and peripheral functions for con-
trolling the desired operation of the device. GPRs are for storage of variables that the
program will need for computation or temporary storage. Some microcontrollers have
additional data EEPROM memory. As with program memory, device data sheets
describe the details of data memory use and operation.
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FIGURE 1-3: PIC® MCU DATA SHEET - FILE REGISTERS
File File File File
Address Address Address Address
Indirect addr. () | 00h Indirect addr. () | 80h Indirect addr. () | 100h Indirect addr. () | 180h
TMRO 01h OPTION_REG |81h TMRO 101h OPTION_REG [181h
PCL 02h PCL 82h PCL 102h PCL 182h
STATUS 03h STATUS 83h STATUS 103h STATUS 183h
FSR 04h FSR 84h FSR 104h FSR 184h
PORTA 05h TRISA 85h PORTA 105h TRISA 185h
PORTB 06h TRISB 86h PORTB 106h TRISB 186h
PORTC 07h TRISC 87h PORTC 107h TRISC 187h
08h 88h 108h 188h
09h 89h 109h 189h
PCLATH 0Ah PCLATH 8Ah PCLATH 10Ah PCLATH 18Ah
INTCON 0Bh INTCON 8Bh INTCON 10Bh INTCON 18Bh
PIR1 0Ch PIE1 8Ch EEDAT 10Ch EECON1 18Ch
PIR2 0Dh PIE2 8Dh EEADR 10Dh EECON2(" | 18Dh
TMR1L OEh PCON 8Eh EEDATH 10Eh 18Eh
TMR1H OFh OSCCON 8Fh EEADRH 10Fh 18Fh
T1CON 10h OSCTUNE |90h 110h 190h
TMR2 11h 91h 111h 191h
T2CON 12h PR2 92h 112h 192h
SSPBUF  |13h SSPADD®@ | 93h 113h 193h
SSPCON 14h SSPSTAT 94h 114h 194h
CCPR1L 15h WPUA 95h WPUB 115h 195h
CCPR1H 16h IOCA 96h IOCB 116h 196h
CCP1CON 17h WDTCON 97h 117h 197h
RCSTA 18h TXSTA 98h VRCON 118h 198h
TXREG 19h SPBRG 99h CM1CONO 119h 199h
RCREG 1Ah SPBRGH 9Ah CM2CONO 11Ah 19Ah
1Bh BAUDCTL 9Bh CM2CON1 11Bh 19Bh
PWM1CON |1Ch 9Ch 11Ch 19Ch
ECCPAS 1Dh 9Dh 11Dh PSTRCON 19Dh
ADRESH 1Eh ADRESL 9Eh ANSEL 11Eh SRCON 19Eh
ADCONO 1Fh ADCON1 9Fh ANSELH 11Fh 19Fh
20h AOh 120h 1A0h
General General
General Purpose Purpose
Purpose Register Register
Register
80 Bytes 80 Bytes
96 Bytes EFh 16Fh
accesses FOh accesses 170h accesses 1FOh
7Fh 70h-7Fh FFh 70h-7Fh 17Fh 70h-7Fh 1FFh
Bank 0 Bank 1 Bank 2 Bank 3

O Unimplemented data memory locations, read as ‘0.
Note 1:  Not a physical register.
Note 2: Address 93h also accesses the SSP Mask (SSPMSK) register under certain conditions.
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In addition to memory, the microcontroller has a number of peripheral device circuits on
the same chip (Figure 1-4). Some peripheral devices are called input/output (1/O) ports.
I/O ports are pins on the microcontroller that can be used as outputs and driven high or
low to send signals, blink lights, drive speakers — just about anything that can be sent
through a wire. Often these pins are bidirectional and can also be configured as inputs,
allowing the program to respond to an external switch, sensor, or to communicate with
some external device.

FIGURE 1-4: PIC® MCU DATA SHEET — BLOCK DIAGRAM (EXCERPT)
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To design such a system, choose which peripherals are necessary for the application.

The following is a list of common peripherals:

» Analog-to-Digital Converters (ADCs) allow microcontrollers to connect to sensors
and receive changing voltage levels.

» Serial communication peripherals that allow streaming communications over a
few wires to another microcontroller, to a local network, or to the Internet.

* Peripherals on the PIC MCU called “timers” accurately measure signal events and
generate and capture communications signals, produce precise waveforms, even
automatically reset the microcontroller if it gets “hung” or lost due to a power glitch
or hardware malfunction.

» Other peripherals detect when the external power is dipping below dangerous
levels, so that the microcontroller can store critical information and safely shut
down before power is completely lost.

The peripherals, and the amount of memory an application needs to run a program,
largely determine which PIC MCU to use. Other factors could include the power con-
sumed by the microcontroller and its “form factor,” i.e., the size and characteristics of
the physical package that must reside on the target design (Figure 1-5).
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FIGURE 1-5: EXAMPLE PIC® MCU DEVICE PACKAGE
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A microcontroller becomes active when power is applied and an oscillator begins gen-
erating a clocking signal (Figure 1-6). Depending on the microcontroller, there may be
several internal and external oscillator operational modes.

FIGURE 1-6: PIC® MCU DATA SHEET — TIMING (EXCERPT)
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1.2.3 Implementing an Embedded System Design with MPLAB X IDE

A development system for embedded controllers is a system of programs running on a
computer to help write, edit, debug and program code — the intelligence of embedded
systems applications — into a microcontroller. MPLAB X IDE is such a system; it con-
tains all the components needed to design and deploy embedded systems applica-
tions.

The typical tasks for developing an embedded controller application are:

1. Create the high level design. From the features and performance desired, decide
which PIC MCU or dsPIC DSC device is best suited to the application, then
design the associated hardware circuitry. After determining which peripherals
and pins control the hardware, write the firmware — the software that will control
the hardware aspects of the embedded application. A language tool such as an
assembler, which is directly translatable into machine code, or a compiler that
allows a more natural language for creating programs, should be used to write
and edit code. Assemblers and compilers help make the code understandable,
allowing function labels to identify code routines with variables that have names
associated with their use, and with constructs that help organize the code in a
maintainable structure.

2. Compile, assemble and link the software using the assembler and/or compiler
and linker to convert your code into “ones and zeros” — machine code for the PIC
MCUs. This machine code will eventually become the firmware (the code pro-
grammed into the microcontroller).

3. Test your code. Usually a complex program does not work exactly the way
imagined, and “bugs” need to be removed from the design to get proper results.
The debugger allows you to see the “ones and zeros” execute, related to the
source code you wrote, with the symbols and function names from your program.
Debugging allows you to experiment with your code to see the value of variables
at various points in the program, and to do “what if’ checks, changing variable
values and stepping through routines.

4. “Burn” the code into a microcontroller and verify that it executes correctly in the
finished application.

Of course, each of these steps can be quite complex. The important thing is to concen-
trate on the details of your own design, while relying upon MPLAB X IDE and its com-
ponents to get through each step without continuously encountering new learning
curves.
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Step 1 is driven by the designer, although MPLAB X IDE can help in modeling circuits
and code so that crucial design decisions can be made.

MPLAB X IDE really helps with steps 2 through 4. Its Programmer’s Editor helps write
correct code with the language tools of choice. The editor is aware of the assembler
and compiler programming constructs and automatically “color-keys” the source code
to help ensure it is syntactically correct. The Project Manager enables you to organize
the various files used in your application: source files, processor description header
files and library files. When the code is built, you can control how rigorously code will
be optimized for size or speed by the compiler and where individual variables and pro-
gram data will be programmed into the device. You can also specify a “memory model”
in order to make the best use of the microcontroller’s memory for your application. If
the language tools run into errors when building the application, the offending line is
shown and can be double clicked to go to the corresponding source file forimmediate
editing. After editing, you will rebuild and try your application again. Often this
write-compile-fix loop is done many times for complex code as the sub-sections are
written and tested. MPLAB X IDE goes through this loop with maximum speed, allowing
you to get on to the next step.

When the code builds with no errors, it needs to be tested. MPLAB X IDE has compo-
nents called “debuggers” and free software simulators for all PIC MCU and dsPIC DSC
devices to help test the code. Even if the hardware is not yet finished, you can begin
testing the code with the simulator, a software program that simulates the execution of
the microcontroller. The simulator can accept a simulated input (stimulus), in order to
model how the firmware responds to external signals. The simulator can measure code
execution time, single step through code to watch variables and peripherals, and trace
the code to generate a detailed record of how the program ran.

When the hardware is in a prototype stage, a hardware debugger, such as an in-circuit
emulator or an in-circuit debugger, can be used. These debug tools run the code in real
time on your actual application by using special circuitry built into many devices with
Flash program memory. They can “see into” the target microcontroller’s program and
data memory, and stop and start program execution, allowing you to test the code with
the microcontroller in place on the application.

After the application is running correctly, you can program a microcontroller with one of
Microchip’s devices or development programmers. These programmers verify that the
finished code will run as designed. MPLAB X IDE supports most PIC MCUs and all
dsPIC DSCs.

DS50002027C-page 18
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1.3 THE DEVELOPMENT CYCLE

The process for writing an application is often described as a development cycle, since
itis rare that all the steps from design to implementation can be done flawlessly the first
time. More often code is written, tested and then modified in order to produce an appli-
cation that performs correctly.

The Integrated Development Environment allows the embedded systems design engi-
neer to progress through this cycle without the distraction of switching among an array
of tools. By using MPLAB X IDE, all the functions are integrated, allowing the engineer
to concentrate on completing the application without the interruption of separate tools
and different modes of operation.

FIGURE 1-7: THE DESIGN CYCLE

Compile/Assemt{-’\

Link Code Download Code to
Debugger

Edit/Create/Design
Source Code Anal)goe(/jlgebug

~——"

MPLAB X IDE is a “wrapper” that coordinates all the tools from a single graphical user
interface, usually automatically. For instance, once code is written, it can be converted
to executable instructions and downloaded into a microcontroller to see how it works.
In this process multiple tools are needed: an editor to write the code, a project manager
to organize files and settings, a compiler or assembler to convert the source code to
machine code and some sort of hardware or software that either connects to a target
microcontroller or simulates the operation of a microcontroller.
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1.4 PROJECT MANAGER

The project manager organizes the files to be edited and other associated files so they
can be sent to the language tools for assembly or compilation, and ultimately to a linker.

The linker has the task of placing the object code fragments from the assembler, com-
piler and libraries into the proper memory areas of the embedded controller, and ensure
that the modules function with each other (or are “linked”).

This entire operation from assembly and compilation through the link process is called
a project “build”. Properties specified for the language tools can be invoked differently
for each file, if desired, and a build process integrates all of the language tools’
operations.

FIGURE 1-8: MPLAB® X IDE PROJECT MANAGER
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The source files are text files that are written conforming to the rules of the assembler
or compiler. The assembler and compiler convert them into intermediate modules of
machine code and placeholders for references to functions and data storage.

The linker resolves these placeholders and combines all the modules into a file of exe-
cutable machine code. The linker also produces a debug file which allows MPLAB X
IDE to relate the executing machine codes back to the source files.

A text editor is used to write the code. It recognizes the constructs in the text and uses
color coding to identify various elements, such as instruction mnemonics, C language
constructs and comments. The editor supports operations commonly used in writing
source code. After the code is written, the editor works with the other tools to display
code execution in the debugger. Breakpoints (which stop or “break” the execution of
code) can be set in the editor, and the values of variables can be inspected by hovering
the mouse pointer over the variable name. Names of variables can be dragged from
source text windows and then dropped into a Watch window where their changing
values can be watched after each breakpoint or during code execution.
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1.5 LANGUAGE TOOLS

Language tools are programs such as cross-assemblers and cross-compilers. Most
people are familiar with some of the language tools that run on a computer, e.g., Visual
Basic or C compilers.

When using language tools for embedded systems, a “cross-assembler” or
“cross-compiler” is used. These tools differ from typical compilers in that they run on a
computer, but they produce code to run on another microprocessor (or microcontroller).

Language tools also produce a debug file that MPLAB X IDE uses to correlate the
machine instructions and memory locations with the source code. This bit of integration
allows the MPLAB X IDE editor to set breakpoints, allows Watches windows to view
variable contents, and lets you single step through the source code, while watching the
application execute.

Embedded system language tools also differ somewhat from compilers that run and
execute on a computer because they must be very space conscious. The smaller the
code produced, the better, because that provides the smallest possible memory usage
for the target, which reduces cost. This means that techniques to optimize and enhance
the code, using machine-specific knowledge, are desirable.

The size of programs for computers typically extends into the megabytes for moder-
ately complex programs. The size of simple embedded systems programs may be as
small as a thousand bytes or less. A medium size embedded system might need 32K
or 64K of code for relatively complex functions. Some embedded systems use
megabytes of storage for large tables, user text messages or data logging.

FIGURE 1-9: A COMPILER CONVERTS SOURCE CODE INTO MACHINE
INSTRUCTIONS

int main (void)

{ 01101111
counter = 1; 10001000
TRISB =0; 11001101
while (inputl = 0) 10100001
{ 00110011

PORTB = count; 01011101
counter++; 00110001
} 11100101

}

© 2011-2014 Microchip Technology Inc. DS50002027C-page 21



MPLAB® X IDE User’s Guide

1.6

TARGET DEBUGGING

In a development environment, the execution of the code is tested on a debugger. The
debugger can be a software program that simulates the operation of the microcontroller
for testing, or it can be a hardware instrument to analyze the program as it executes in
the application.

1.6.1 Software Debuggers

Simulators are built into MPLAB X IDE so a program can be tested without any addi-
tional hardware. A simulator is a software debugger, and the debugger functions for the
simulator are almost identical to the hardware debuggers, allowing a new tool to be
learned with ease. Usually, a simulator runs somewhat slower than an actual microcon-
troller, since the CPU in the computer is being used to simulate the operations of the
microcontroller.

1.6.2 Hardware Debuggers

There are two types of hardware that can be used with MPLAB X IDE: programmers
and hardware debuggers. A programmer simply burns the machine code from the PC
into the internal memory of the target microcontroller. The microcontroller can then be
plugged into the application and, hopefully, it will run as designed.

Usually, however, the code does not function exactly as anticipated, and the engineer
is tasked with reviewing the code and its operation in the application to determine how
to modify the original source code to make it execute as desired. This process is called
debugging. As noted previously, the simulator can be used to test how the code will
operate, but once a microcontroller is programmed with the firmware, many things out-
side the scope of the simulator come into play. Using just a programmer, the code could
be changed, reprogrammed into the microcontroller and plugged into the target for
retest, but this could be a long, laborious cycle if the code is complex, and it is difficult
to understand exactly what is going wrong in the hardware.

This is where a hardware debugger is useful. Hardware debuggers can be in-circuit
emulators or in-circuit debuggers, which use microcontrollers that have special built-in
debugging features. A hardware debugger, like a simulator, allows the engineer to
inspect variables at various points in the code, and single step to follow instructions as
the hardware interacts with its specialized circuitry.

1.6.3 Integrated Development Environment

Debugging usually becomes urgent near the end of the project design cycle. As dead-
lines loom, getting the application to function as originally designed is the last step
before going into deployment of the product, and often has the most influence on pro-
ducing delays in getting a product out. That’'s where an integrated development envi-
ronment is most important. Doing fine “tweaks” to the code, recompiling, downloading
and testing all require time. Using all tools within a single environment will reduce the
time around the “cycle.” These last steps, where critical bugs are worked out, are a test
for the embedded systems designer. The right tool can save time. With MPLAB X IDE
many tools can be selected, but they all will have a similar interface, and the learning
curve from simulator to low-cost in-circuit debugger to powerful in-circuit emulator is
small.
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1.7 DEVICE PROGRAMMING

After the application has been debugged and is running in the development environ-
ment, it needs to be tested on its own. A device can be programmed with an in-circuit
emulator, an in-circuit debugger, a development programmer, or a device programmer.
MPLAB X IDE can be set to the programmer function, and the part can be “burned”.
The target application can now be observed in its nearly final state. Engineering proto-
type programmers allow quick prototypes to be made and evaluated. Some applica-
tions can be programmed after the device is soldered on the target PC board. Using
In-Circuit Serial Programming™ (ICSP ™) programming capability, the firmware can be
programmed into the application at the time of manufacture, allowing updated revisions
to be programmed into an embedded application later in its life cycle. Devices that sup-
port in-circuit debugging can even be plugged back into an in-circuit debugger after
manufacturing for quality tests and development of next generation firmware.

Production programming can be accomplished using a production programmer and the
MPLAB IPE, which is installed with MPLAB X IDE.
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1.8

COMPONENTS OF MPLAB X IDE

MPLAB X IDE includes:

+ a full-featured programmer’s text editor that also serves as a window into the
debugger.

* a project manager (visible as the Projects window) that provides integration and
communication between the IDE and the language tools.

» a number of assembler/linker suites for the development of firmware for your proj-
ect’s device.

» a debugger engine that provides breakpoints, single stepping, Watch windows
and all the features of a modern debugger. The debugger works in conjunction
with debug tools, both software and hardware.

+ a software simulator for all PIC MCU and dsPIC DSC devices. The simulator is
actually composed of several device-specific simulator executables. MPLAB X
IDE decides which one to use based on your project’s device.

Optional components can be acquired or purchased to work with the MPLAB X IDE:
* Compiler Language Tools

MPLAB XC C compilers from Microchip provide fully integrated, optimized code for PIC
MCUs and dsPIC DSCs. Along with compilers from microEngineering Labs, CCS and
SDCC, they are invoked by the MPLAB X IDE project manager to compile code that is
automatically loaded into the target debugger for instant testing and verification.

* Programmers

MPLAB ICD 3 in-circuit debugger, MPLAB REAL ICE™ in-circuit emulator, and MPLAB
PM3 programmer are capable of the production programming of code into target
devices. PICkit™ 3 in-circuit debugger is capable of the development programming of
code into target devices.

All of these tools may be used with MPLAB X IDE to control programming of both code
and data, as well as the Configuration bits to set the various operating modes of the
target microcontrollers or digital signal controllers.

In addition, all of these tools may be used with MPLAB IPE to program code, data and
configuration bits. MPLAB IPE is designed more for production programming, and its
interface is simplified to do just that.

* In-Circuit Debuggers and Emulators

PICkit 3 and MPLAB ICD 3 in-circuit debuggers, and MPLAB REAL ICE in-circuit emu-
lator can be used to debug application code on target devices. By using some of the
on-chip resources, these can download code into a target microcontroller inserted in
the application, set breakpoints, single step and monitor registers and variables. The
emulator includes additional debug features, such as trace.

* Plug-In Tools

Several plug-ins are available to add to the capabilities for MPLAB X IDE. For example,
the Data Monitor and Control Interface (DMCI) provides a mechanism to view and con-
trol variables in code and change their values real-time. It also allows you to view output
data in a graphical format.

For more on the plug-in tools supported, see Section 5.21 “Add Plug-In Tools”.
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1.9 MPLAB X IDE ONLINE HELP

MPLAB X IDE is built upon the NetBeans platform. Therefore, many of the NetBeans
functions are now MPLAB X IDE functions.

Please refer to all help files for a complete understanding of MPLAB X IDE behavior.
To launch help, select Help>Help Contents. This merges all help files into one, so it may
take a little more time to open.

For NetBeans information, see the online help files under “NetBeans Help” in the table
of contents. For all MPLAB X IDE development tool information, see the online help
files under “MPLAB X IDE Help” in the table of contents.

You can also view individual help files for selected tools under Help>Tool Help
Contents. Launching an individual help file will be faster and provide a smaller search
of topics.

For a comparison of MPLAB X IDE and MPLAB IDE v8, see Chapter 10. “MPLAB X
IDE vs. MPLAB IDE v8”.
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1.10 OTHER MPLAB X IDE DOCUMENTATION

In addition to help, links to other documentation, videos, forums, and wikis are featured
on the Start Page (Figure 1-10).

The MPLAB X IDE Wiki is a good place to look for tips on advance features
(Figure 1-11).

FIGURE 1-10: MPLAB® X IDE START PAGE
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FIGURE 1-11:

MPLAB® X IDE WIKI
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111 WEB SITE

Microchip provides online support via our web site at:
http://www.microchip.com/devtools

This web site make files and information easily available to customers. For more
details, see Support.

1.12 MPLAB X IDE UPDATES

MPLAB X IDE is an evolving program with thousands of users. Microchip Technology
is continually designing new microcontrollers with new features. Many new MPLAB X
IDE features come from customer requests and from internal usage. Continued new
designs and the release of new microcontrollers ensure that MPLAB X IDE will con-
tinue to evolve.

MPLAB X IDE is scheduled for a version update approximately every few months to
add new device support and new features.

For projects that are midway through development when a new version of MPLAB X
IDE is released, it is considered “best practice” to not update to the new release unless
there is a compelling reason to do so, such as a bug fix on a bug that inhibits the current
efforts. The start of a new project is the best time to update to a new release.

Each new release of the MPLAB X IDE software has new features implemented, so the
printed documentation will inevitably “lag” the online help. The online help is the best
source for any questions about MPLAB X IDE.

To be notified of updates to MPLAB X IDE and its components, subscribe to the
Development Tools section of myMICROCHIP Personalized Notification Service on:

http://www.microchip.com/pcn

For more details, see Support.
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Chapter 2. Before You Begin

21 INTRODUCTION

Before you can use MPLAB X IDE you must do the following:
* Install JRE and MPLAB X IDE

* Install the USB Device Drivers (For Hardware Tools)

» Connect to a Target (For Hardware Tools)

* Install the Language Tools

* Launch the IDE

» Launch Multiple Instances of the IDE

2.2 INSTALL JRE AND MPLAB X IDE

When you install MPLAB X IDE (based on the NetBeans platform), the correct Java
Runtime Environment (JRE) for Windows operating system (OS) or Linux OS will be
installed. For Mac OS, if the correct JRE is already installed, the MPLAB X IDE install
will proceed. If not, you will be prompted by a dialog to acquire the correct version.
Follow the instructions, install the JRE, and then install MPLAB X IDE.
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2.3 INSTALL THE USB DEVICE DRIVERS (FOR HARDWARE TOOLS)

For correct tool operation, you might need to install USB drivers.

2.31 USB Driver Installation for Mac or Linux Operating Systems

When you install MPLAB X IDE on a Mac or Linux box, the installer will place the USB
drivers for you. You do not need to do anything.

2.3.2 USB Driver Installation for Windows® XP/7/8 Operating Systems

If you install MPLAB X IDE on a personal computer uses Windows OS, follow the
instructions below to correctly install the USB drivers. (The USB hardware tool drivers
for MPLAB IDE v8.xx are not the same as those for MPLAB X IDE.)

These instructions apply to the following tools:

* MPLAB REAL ICE in-circuit emulator
* MPLAB ICD 3 in-circuit debugger

+ MPLAB PM3 device programmer

» PIC32 Starter Kit

You do not need to do anything for PICKkit 2, PICkit 3 or other MPLAB Starter Kits.
Follow the instructions below to determine your installation method.

2.3.21 BEFORE YOU INSTALL THE DRIVERS

Whether you use the Switcher utility or activate the preinstaller to install your drivers
(both discussed in following sections), be aware that your system’s version of WinUSB
drivers will be replaced if they are older than the Switcher or preinstaller version. If you
want to keep your version of WinUSB drivers, rename these files before installing any
Microchip device driver.

The WinUSB driver files are located at the following locations:
32-bit OS

C:\Windows\system32\WinUSB.d1l1l (32-bit)
C:\Windows\system32\drivers\WinUSB.sys (64-bit)
64-bit OS

C:\Windows\SysWOW64\WinUSB.d1ll (32-bit)
C:\Windows\system32\WinUSB.d1l1l (64-bit)
C:\Windows\system32\drivers\WinUSB.sys (64-bit)

2.3.22 IF YOU HAVE WINDOWS XP 64, MANUALLY SWITCH

If using the Windows XP 64-bit OS, you will have to switch the device drivers manually.
See Section 2.3.2.6 “If You Need to Manually Install the Drivers”.
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2.3.23 IF YOU HAVE WINDOWS 7 OR 8, USE ADMINISTRATOR MODE

If you will use the Switcher executable to install your device drivers, you must be in
Administrator mode to run this program on Windows 7 or 8.

To run the Device Driver Switcher GUI application as administrator, right click on the
executable — MPDDSwitch.exe or MPDDSwitch64 . exe — and select ‘Run as
Administrator’.

It is recommended that you use the GUI application first to switch the drivers. If this is
problematic, you may switch the drivers using command-line applications.

To run the command-line application — mchpdds32 . exe or mchpddsé64 .exe — as
administrator, first open the command prompt in Admin mode: Start>All
Programs>Accessories>Command Prompt, right click and select ‘Run as Administra-
tor’. This will open up the Administrator: Command Prompt. After this, the instructions
provided in the ReadMe32 . txt or ReadMeé64 . txt file may be followed to complete
the driver switching.

23.24 IF MPLAB IDE V8.XX IS ALREADY INSTALLED ON YOUR SYSTEM

If MPLAB IDE v8.xx or earlier is already installed on your computer, you will run the
Switcher program to switch from MPLAB IDE v8 drivers to MPLAB X IDE drivers, which
are installed the first time your switch.

The Switcher program is a GUI application called MPDDSwitch (32-bit OS) or
MPDDSwitch64 (64-bit OS). This should be available as the desktop icon MPLAB
Driver Switcher.

FIGURE 2-1: SWITCHER UTILITY
. MPLAB Device Driver Switcher =
Tool Group Driver Selection
Tool Group and Action: Group Driver Selection to be Applied:

3 ange
ICD3 : Mo Change
PM3 : Mo Change
PIC32 5K : Mo Change

MPLAE & MPLAEX Do Mot Change

' r o Apply Changes Close

Make sure that the tool you want to switch is plugged into your system,

MPDDSwitcha4, v1.04.03

Flug in ONLY the tools you want switched. All other tools should be unplugged.

Advanced =
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1. Plug your desired tool into USB connector on your personal computer.

2. Open the computer’s Device Manager window. For example, on a personal com-
puter running Windows XP, right click on the My Computer icon and select “Prop-
erties”. In the System Properties dialog, click the Hardware tab and then click the
Device Manager button.

3. Expand the “Microchip Tools” section to view the current driver for your tool. The
name should be of the form: Microchip Tool Name.

4. Go to the MPLAB X IDE install folder and find the Switcher folder, by default:
a) 32-bit OS: c:\Program Files\Microchip\MPLABX\Switcher
b) 64-bit OS: ¢:\Program Files (x86)\Microchip\MPLABX\Switcher
5. Under the switcher folder, go to the folder for your operating system - 32Bit
or 64Bit.
6. Launch MPDDSwitch.exe (32-bit OS) or MPDDSwitché64 . exe (64-bit OS).
7. If your MPLAB IDE v8 or MPLAB X IDE installation is not in the default directory,
click Advanced to specify the location of the driver files.
8. To install or switch USB drivers:
a) Click to select the connected tool for which you wish to switch drivers under
“Tool Group and Action”.
b) Click the radio button for either “MPLAB 8” or “MPLAB X".
c) Click Apply All. Switcher progress will be shown in the large text window.
This may take some time.

Note: If the tool(s) are not connected when Switcher is run, the driver(s) will
not be installed or switched for those particular tools.

9. If the GUI fails to install the drivers, check the paths to the driver files by clicking
Advanced. Run the Switcher again.

10. If the GUI still fails to install the drivers, you will need to install the drivers manu-
ally. For instructions and driver locations, see Section 2.3.2.6 “If You Need to
Manually Install the Drivers”.

11. Once the program/batch completes, view the name of the drivers in the Device
Manager window. It should say “Microchip WinUSB Device”.

Once your MPLAB X IDE drivers are installed, you can switch your drivers back and
forth between MPLAB IDE v8.xx and MPLAB X IDE.

2.3.25 IF MPLAB IDE V8.XX IS NOT INSTALLED ON YOUR SYSTEM

You do not need to do anything; the USB drivers will be preinstalled when MPLAB X
IDE is installed. Once you plug your tool into a computer USB port, a “New Hardware
Found” notification should appear. Then either the install will proceed automatically or
your will have to follow a wizard and choose to “Automatically select driver’. However,
if either procedure fails to install the drivers, you will need to install the drivers manually.
For instructions and driver locations, see Section 2.3.2.6 “If You Need to Manually
Install the Drivers”.
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2.3.26 IF YOU NEED TO MANUALLY INSTALL THE DRIVERS

If you need to install the drivers manually:

1. Open the Device Manager (under Control Panel). Look under “Microchip Tools”
for your tool or, if you cannot find it there, under “Other Devices” for “Unknown

Device”.

2. Right-click on your tool name or “Unknown Device” and select “Update Driver
Software”.

3. Inthe Update Driver Software dialog, select “Browse my computer for driver
software”.

Note: DO NOT select “Search automatically for updated driver software”.
This will install the wrong device driver. If you accidentally select this,
back out or exit and repeat these steps to install the correct driver.

4. Locate the correct device driver for your system. The default locations for the
device drivers are:

C:\Program Files\Microchip\MPLABX\Switcher\32Bit\winusb\
x86 \MCHPWinUSBDevice.inf

or

C:\Program Files\Microchip\MPLABX\Switcher\64Bit\winusb\
amd64 \MCHPWinUSBDevice.inf

For Windows 8, the drivers are in either the x86_Windows8 orin the
amdé4 Windows8 subfolder.

5. If a Windows Security dialog pops up, select “Install this driver software anyway”
to proceed to install the drivers.

2.3.2.7 TOOL COMMUNICATION ISSUES

1. If you are using a docking station or hub and have issues after plugging in the
tool, you may need to plug the tool directly into a USB port on your computer.
This is a known issue with the WinUSB driver.

2. If you need to reinstall a driver manually, you will need to point to the INF file in
the 32Bit or 64Bit folder. See Section 2.3.2.6 “If You Need to Manually
Install the Drivers” for details.
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24 CONNECT TO A TARGET (FOR HARDWARE TOOLS)

For in-circuit debuggers and emulators, refer to the following to determine how to
connect your hardware tool to a target:

+ the Development Tools Design Advisory

 the Header Specification (if you are using a header)

* your tool documentation

For dedicated programmers, refer to your tool documentation for connection
information.

If you are using a Microchip demonstration board, evaluation kit or reference design as
your target, please refer to the accompanying documentation for set up information.

2.5 INSTALL THE LANGUAGE TOOLS

When you install MPLAB X IDE, the following language tools are installed as well:
MPASM toolchain (ASM30 toolchain no longer included).

Currently there are several C compiler toolsuites (compiler, assembler, linker, etc.) that
can be used with MPLAB X IDE. Go to the Microchip web site:

http://www.microchip.com/xc

where you can find free compilers (Free, Evaluation) and full-featured, code-optimized
compilers (Standard, Pro).

To select a compiler toolsuite, consider which device you wish to use and then choose
a toolsuite that supports that device.

To install and license the compiler you want, view the document /nstalling and
Licensing MPLAB XC C Compilers (DS50002059). MPLAB X IDE includes the option
to license your installed compiler and roam in and out network licenses. See the
“Licenses” option under Section 11.2.10 “Tools Menu”.
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2.6 LAUNCH THE IDE

Double click on the MPLAB X IDE icon to launch the program.

MPLAB X IDE is built upon the NetBeans platform. If you are familiar with the NetBeans
IDE, then the MPLAB X IDE desktop will look familiar.

FIGURE 2-2: MPLAB® X IDE DESKTOP
B MPLAE X 10 w198 o o5
_Flle Ed® View Plywigete Soumce Refsctor R Debugy Tesr Took Windoew  Help
..'-_*_ J B - - - - e | ecoe T
StwtFage = L =&

Gl Siart _ Minure Vedeos [ 1,.. Fesums
]
ﬁ\ BFLAB IDE v Users - IIPORTANT & Diferences froom WIPLAE B .x.] BAPLAB X IDE Fonesm
\_ -
1 " Take s Towr &ll Tutorule == S5 WPLAB Harmony Forum

@ Dreenicad ©ocmpilsry and Assemblers 0 BAPLAR X I Wik

Beleann Hobex and Support Docementabion

¢ g
[ L AR Haremony

Open Sample Progect
Create Hew Projsct
Import MPLAR Lagacy Progect

Impor Ha (Pretsult] Progact

ﬁ‘h:m | Show On Starup + NetBgans
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On the Start Page, there are 3 tabs with links. The items on each tab are defined below.

TABLE 2-1: LEARN AND DISCOVER

Getting Started

Quick Start Get started quickly by creating and setting up a project.
MPLAB® IDE v8 Users — | Install WinUSB device drivers for your hardware tools.
IMPORTANT

Take a Tour Take a tour of MPLAB X IDE operation.

MPLAB® X IDE Limitations

What is and is not currently supported on this version.

Dive In

Open Sample Project

Open a functional project as an example.

Create New Project

Create a new MPLAB X IDE project. It is recommended that you
view the “Quick Start” before creating your first project.

Import Legacy Project

Import your existing MPLAB IDE v8 project. It is recommended
that you view the “Quick Start” before working with an imported
project.

New (Hex) Prebuilt Project

Import the hex file from a prebuilt project for another tool.

Demos and Tutorials

Minute Videos

View short videos explaining MPLAB X IDE operation.

Difference from MPLAB v8

View differences between MPLAB X IDE and MPLAB IDE v8.

All Tutorials

View all available tutorials.

Community

Forums

Go to the Microchip forums web page.

MPLAB X IDE Forum

Register for the MPLAB X IDE forum.

MPLAB X IDE Wiki

Open the MPLAB X IDE developer’s help center.

TABLE 2-2:

MY MPLAB X IDE

Recent Projects

MyProject.c:

List of recently opened projects.

Extend MPLAB

Selecting Simple or Full
Featured Menus

On initial start-up, MPLAB X IDE displays simple menus. For more
features, follow these instructions.

Install More Plug-Ins

Open the plug-ins dialog.

Notes and Newsletters

ANXxxx, TBxxxx

Featured application notes and technical briefs.

microSOLUTIONS
E-newsletter

Featured newsletters.

All App Notes/
Newsletters

View all available.

References and Featured

Links

Data Sheets, etc.

Click a link to go to the item described.
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TABLE 2-3: WHAT’S NEW
Data Sheets and Errata

Data Sheet, Silicon List of featured data sheets and errata. To see a list of all these
Errata documents, all click “All Data Sheets” or “All Errata”.

Reference Manuals and Programming Spec

Family Reference Man- | List of featured reference manuals and programming specifica-
ual, Device Program- tions. To see a list of all these documents, all click “All Reference
ming Spec Manuals” or “All Programming Specs”.

Recently Released Software

Source code List of recent software supporting Microchip device development.
To see a list of all these documents, all click “All Recently
Released Software”.

Product and Corporate News

New stuff, new news List of featured Microchip products and news. To see a list of all
these documents, all click “All News”.
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2.7 LAUNCH MULTIPLE INSTANCES OF THE IDE

Some setup is required before using hardware tools (PICkit 3, etc) with an instance of
MPLAB X IDE. After any hardware tool setup, an instance of the IDE may be invoked
from its own directory.

» Setting Up Hardware Tools to Work with Multiple Instances
* Invoking Instances of the IDE

271 Setting Up Hardware Tools to Work with Multiple Instances

By default, you can work with up to five (5) instance of the IDE. If you want to have more
instances, you will need to manually modify the “mchpdefport” file.

2.71.1 USE AND FORMAT OF “MCHPDEFPORT” FILE

The “mchpdefport” file provides the information necessary for tool hot-plug use to both
the IDE and to the low-level USB library (DLL, so, or dylib file). The format for this file
is as follows:

localhost
30000
30002
30004
30006
30008

The first line indicates the host name on which the IDE is running.

The other lines represent port or socket numbers through which the low-level library
communicates with the upper-level IDE. Each instance of the IDE will be assigned to a
different port or socket. All communications between the instances of the IDE should
be hidden from the user.

For up to five (5) instances of MPLAB X IDE, you do not need to alter this file. If you
want more than five instances, you can edit the file to add more port or socket numbers.

2.71.2 LOCATION OF THE “MCHPDEFPORT” FILE

Within a default installation of the IDE, the “mchpdefport” file can be found in the follow-

ing places:
os Location
Windows (64-bit) C:\Windows\system32
and
C:\Windows\SysWOWe64
(Both occurrences of “mchpdefport” must be modified.)
Windows (32-bit) C:\Windows\system32
Linux /etc/.mplab ide
Mac (OSX) /etc/ .mplab_ide
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2.7.2 Invoking Instances of the IDE

MPLAB X IDE requires each instance to have its own user directory. Therefore,
preferences set or plug-ins added to one instance will not be reflected in another.

In order to invoke multiple instances launch the IDE with the —--userdir option and
specify a directory.

2.7.21  WINDOWS 0OS

Create a shortcut with the - -userdir option. For example:

1. Right click on the desktop and select New>Shortcut.

2. Browse to the installed MPLAB X IDE executable, by default at:
"C:\Program Files\Microchip\MPLABX\mplab ide\bin\
mplab ide.exe"

3. Atthe end of the line, enter:

--userdir "C:\Documents and Settings\MyFiles\
ApplicationData\.mplab ide\dev\beta7Instance2"
4. Click OK.

2.7.22 LINUXOS

The installed version run without any parameters (clicking on the desktop icon) will run
with a user directory of $ (HOME) / .mplab ide. To change the user directory, run the
$InstallationDir/mplab ide/bin/mplab_ide shell script passing the
argument - -userid anydir. For example, to run MPLAB X IDE in two different
instances:

$ /opt/microchip/mplabx/mplab ide/bin/mplab ide --userdir ~/.anydirl &
$ /opt/microchip/mplabx/mplab ide/bin/mplab ide --userdir ~/.anydir2 &

You can create desktop icons that have the user ID embedded too.

2723 MACOS

Open a Shell window and type the following command line to execute your installation
of MPLAB X IDE (example: Beta 7.12) in the alternate user directory:

$/bin/sh /Applications/microchip/mplabx/712/mplab ide.app/Contents/
Resources/mplab ide/bin/mplab ide --userdir "${HOME}/Library/
Application Support/mplab ide/dev/beta7.12”
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NOTES:
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Chapter 3. Tutorial

3.1  INTRODUCTION

This tutorial provides a guided example for working with an MPLAB X IDE project.

 Setting Up the Hardware and Software
- Tutorial Equipment
- Installation and Set Up

» Creating and Setting Up a Project
- Create a New Project
- View Changes to the Desktop
- View or Make Changes to Project Properties
- Set Options for Debugger, Programmer or Language Tools
- Set Language Tool Locations
- Add An Existing File to the Project
- Editor Usage
- Configuration Bits
* Running and Debugging Code
- Build a Project
- Run Code
- Debug Run Code
- Control Program Execution with Breakpoints
- Step Through Code
- Watch Symbol Values Change
- View Device Memory (including Configuration Bits)
- Program a Device
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3.2 SETTING UP THE HARDWARE AND SOFTWARE

The following information discusses preparation to begin using the MPLAB X IDE.

3.21 Tutorial Equipment

The products used in this tutorial are:

Tool Web Page Order Number
MPLAB® X IDE http://www.microchip.com/mplabx Free
MPLAB® XC32 C http://www.microchip.com/xc SW006023-1
Compiler* (Standard Version)
MPLAB® REAL ICE™ http://www.microchip.com/realice DV244005

in-circuit emulator

Explorer 16 http://www.microchip.com/explorer16 DM240001
Development Board

PIC32MX360F512L PIM | http://www.microchipdirect.com/product- MA320001
search.aspx?Keywords=MA320001

* You may acquire a free or evaluation edition of this compiler from the microchip website.
Download the compiler and, when installing, do not enter a license number.

3.2.2 Installation and Set Up

See Chapter 2. “Before You Begin” to install MPLAB X IDE, set up the emulator
(install USB drivers and properly connect to your target), and install the 32-bit language
tools. Then launch MPLAB X IDE and begin this tutorial.
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3.3 CREATING AND SETTING UP A PROJECT

The following information discusses setting up projects in MPLAB X IDE, which are
required to develop your application code.

3.31 Create a New Project

MPLAB X IDE is project-based, so you must set up a project to work on your
application.

New projects can be created by selecting either:

 Start page, Learn & Discover tab, “Dive In” section, “Create New Project” link
* File>New Project (or Ctrl+Shift+N)

The New Project Wizard will launch to guide you through new project set up.

STEP 1

Step 1 asks you to choose a project category.

This is a NetBeans dialog. To work with Microchip products, choose “Microchip
Embedded”.

Secondly, choose a project type. For this tutorial, choose “Stand-alone Project”.
Click Next> to move to the next dialog.

FIGURE 3-1: PROJECT WIZARD - CHOOSE PROJECT
x New Project : 3l
Steps Choose Project
1. Choose Project Categories: Projects:
2 .. Enl:ed:led [& standalone Project
. ..... )\ Other Embedded [&J Existing MPLAB IDE v8 Project

@ Prebuilt (Hex, Loadable Image) Project

- ) Samples
@ Library Project

Description:

Creates a new standalone application project. It uses an IDE-generated makefile to build your
project.

Finish Cancel | | Help
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STEP 2

Step 2 is for choosing your device, in this case PIC32MX360F512L. When you are
done, click Next>.

FIGURE 3-2: PROJECT WIZARD - SELECT DEVICE
x New Project = |
Steps Select Device

Choose Project
Select Device
. Select Header Family: 32-bit MCUs (PIC32) -

. Select JTAG Plugin Board

. Select Compiler

. Select Project Name and
Folder

Device: PIC32M 360 2 o

A,

2.

3

4. Select Tool
5

]

7.

< Back Finish Cancel Help

STEP 3

Step 3 only appears if a header is available for your selected device. Since there is no
header for the PIC32MX360F512L device, MPLAB X IDE knows to skip this step.
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STEP 4

Step 4 selects the tool.

Tool support for the selected device is signified by the colored circles (lights) in front of
the tool name. If you cannot see the colors, mouse over a light to pop up text about

support.
Light Color Support
@) Green Full (Implemented and fully tested)
) Yellow Beta (Implemented but not fully tested)
) Red None

For some tools, there are two lights next to the tool name, where the first light is the
left-most light and the second light is to the right of the first.

Light No. Debug Tools Simulator
1 Debugger Support Core (Instruction Set) Support
2 Programmer Support Peripheral Support

For the hardware tools, you will notice that a serial number (SN) is specified below any
tool that is connected to your computer. This allows you to select from several
connected hardware tools.

Select your tool and then click Next>.

FIGURE 3-3: PROJECT WIZARD - SELECT TOOL
x New Project | RS |
Steps Select Tool

. Choose Project
. Select Device
. Select Header

| Hardware Tools -

. Select JTAG Plugin Board

. Select Compiler

. Select Project Name and
Folder

1
2.
3
4. Select Tool
5
6
7.

m

20 Simulator
Microchip Starter Kits

-@ MCHV

-@ MICROSTICK

-@ SKDE 33 AUDIO

-@ SKDE Memory

-@ SKDE PIC18F]

-@ SKDE PIC24F 1

tgy SKDF PTIC24H SFNSOR
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STEP 5

Step 5 only appears if MPLAB REAL ICE in-circuit emulator is selected as the tool.

For the MPLAB REAL ICE in-circuit emulator, you may specify a plug-in board to use.
A plug-in board is the circuit board that is inserted into the emulator’s driver board slot.
Since the Explorer 16 board works with either the Standard or High-Speed Communi-
cations driver boards, leave the “Supported Plugin Board” as “None”.

Select your tool and then click Next>.

FIGURE 3-4: PROJECT WIZARD - SELECT PLUGIN
x New Project RS

Steps Select Plugin Board
1. Choose Project
2, Select Device * OPTIOMAL: Please select an associated plugin board if present
3. Select Header
;' iﬂféﬁ:ﬁ’ﬂgin B @pporh&d Plugin Board: Mone D
6. Select Compiler
7. Select Project Name and

Folder A plug in board is a daughter board for the REAL ICE that provides spedialized

debugging and/or programming features.
< Back Finish Cancel Help
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STEP 6

Step 6 selects the language tool, either a C compiler or assembler. Again, the colored
circle (light) in front of the compiler name signifies the device support level. Mouse over
for text.

The version and installation location of a language tool is displayed beneath that tool.
This allows you to select from several installed language tools.

Select your tool and then click Next>.

FIGURE 3-5: PROJECT WIZARD - SELECT LANGUAGE TOOL
x New Project |i|
Steps Select C

1. Choose Project
2. Select Device . Compiler Toolchains
3. Select Header =
4. Select Tool
5

6.

7.

-2 €32 (v2.02) [C:\Program Files (x86) Microchip\MPLAB C32 Suite'bin]

Select ITAG Plugin Board HI-TECH PICC32 (None found)

Select Compiler
Select Project Name and

Folder L [ (v1.11) [C:\Program Files (x86)Microchipixc32'v 1. 11%bin]
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STEP 7

Step 7 selects the project name, location and other project options.

Enter the project name MyProject.

By default, projects will be placed in:

* Windows XP — C:\Documents and Settings\UserName\MPLABXProject
* Windows 7/8 — C: \Users\UserName\MPLABXProjects

* Linux — /home/UserName/MPLABXProjects

* Mac — /Users/UserName/MPLABXProjects

If the Project Location does not point here, browse to the appropriate location.
Check “Set as main project” to make this your main project.

This tutorial was produced with the encoding set to ISO-8859-1 (Latin 1) so you do not
need to change this setting.

When you are done, select Finish to complete new project creation.

FIGURE 3-6: PROJECT WIZARD - SELECT PROJECT NAME AND
FOLDER
x New Project [ ]
Steps Select Project Name and Folder
1.  Choose Project
2. Select Device Praject Name: MyProject
3. Select Header
s ::}:g;?:g o ) Praject Location: C:\Users\c08227, MCHP-MAINWMPLABKPrajects Brawse...
67‘_ gif;tf ;r:gl:;t Ml Project Folder: C:\Users\F08227, MCHP-MAIN\MPLASXProjects\MyProject.X
Folder

Overwrite existing project.
Alzo delete sources,

V| Set as main project

Enceding: [S0-8859-1 -

< Back ext > Finish H Cancel H Help
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3.3.2

View Changes to the Desktop

Once you have created your project, several panes will open in the IDE.

File pane — A pane with four tabbed windows - Projects, Files, Classes and Ser-

vices (not shown automatically) windows. In this tutorial, we will focus on the
Projects window, which displays the project tree with files grouped by category.

Navigation pane — A pane that displays information on the file or project selected.

For a project, the project environment shows details about the project and for a

file, symbols and variables are shown.

visible here.

an application.

FIGURE 3-7: MPLAB X IDE DESKTOP

Editor pane — A pane for viewing and editing project files. The Start Page also is

Task pane — A pane that displays task output from building, debugging or running
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If you double click on any file name in the File pane, the related file will open in the

Editor pane under a tab next to the Start Page. To close the tab, click on the

the file name.

X" next to

Right click on the project name in the File pane, Projects window, to view the pop-up
(context) menu. Do the same for the project’s subfolders.
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3.3.3

Once a project has been created, you can view or change the project properties in the
Project Properties dialog.

View or Make Changes to Project Properties

Access this dialog by either:

* right clicking on the project name in the Projects window and selecting
“Properties”.

+ clicking on the project name in the Projects window and then selecting
File>Project Propetrties.

Click the “Conf:[default]” category to reveal the general project configuration, such as
the project device, related debug/programmer tool, and language tool. Do not change
any of these items for this tutorial unless you have made a mistake in previous sections.

Then update in this dialog and click Apply.

FIGURE 3-8: PROJECT PROPERTIES DIALOG
x Project Properties - MyProject | |
Categories: Configuration
;o @ General
5 @ Family: Device:
: @ Real ICE All Families - PICI2MX360F 5120 -
i @ Loading
= Libraries Supported Debug Header: Supported Plugin Board:
@ Building None None -
@ X¥C32 (Global Options)
- @ xc32-as
o xc32gee Hardware Tool: Compiler Toolchain:
. o xcizg+ Hardware Tools - Compiler Toolchains
-@ PICkit2 e C32 (v2.02) [C:\Program Files (x&6) V)
--0i@ PICKt3 -HI-TECH PICC32 (MNone found)
0 PM3 —1-XC32
o0 RealICE
i@ Simulator =
- Microchip Starter Kits
L@ MCHY
MICROSTICK
SKDE 33 AUDIO
SKDE Memory
SKDE PIC18F]
SKDE PIC29F 1
O SKDE PIC24H SENSOR.
-1 SKDE PIC32 v L n r
*Tip: double dick on serial number (SN) to use a friendly name (FN) instead.
Manage Configurations. ..
Ok I | Cancel | | Apply | | Help
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3.34 Set Options for Debugger, Programmer or Language Tools

Additionally, you set options for your tools in the Project Properties dialog.
To set up or change debugger/programmer tool options:

» Click on REAL ICE to see related setup options. For more on what these options
mean, see the emulator documentation.

Do not make any changes for this tutorial.

FIGURE 3-9: TOOL SETUP PAGE

Project Properties - MyProjs §1
] P My

Categories: T
jons for Real
| @ General *
=- e Conf: [default] Option categories: | Memories to Program v
W =al 1CE ] ]
H Loading luto select memories and ranges Allow Real ICE to Select Memories -
Libraries Configuration Memory {always programmed in deb...|
Buildiny
) Boot Flash (always programmed in debug mode)
¥C32 (Global Options)
i @ xc32-8s Program Memary
; @ xc32-gec Program Memory Start (hex) 0x1d000000
i @ XC32-g++
Program Memory End  (hex O 1dO T
b @ xc32Ad h ! thex)
Preserve Program Memory |:|
Preserve Program Memory Start (hex) 014000000
Preserve Program Memory End  (hex) O 107

Option Description

Manage Configurations. ..

Ok ” Cancel ” Apply ” Help
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To set up or change language tool options:

+ Click on your language tool to see related setup options. For more on what these
options mean, see your language tool documentation.

Do not make any changes for this tutorial.

FIGURE 3-10: LANGUAGE TOOL SET UP PAGE

B
Categories: o for we32- 1.19)
o g — ptions for xc32-gee (v1.
Bl @ Conf: [defaul] Option categories: | General -
i @ Real ICE
H Loading Have symbals in production build -
Libraries Enable App IO &
Buildin
8 . solate each function in a section E
¥C32 (Global Options)
i 0 xc32as Place data into its own section |}
o @ Use indirect calls [ =
@ xc32g++
H Generate 16-bit code
e @ xc324d 0
Exclude floating-point library =
Preprocessor macros [
ncdude directories [l -
Additional options:
Option Description | Generated Command Line
Manage Configurations...
OK. ] [ Cancel ] [ Apply ] [ Help
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3.35 Set Language Tool Locations

To see what language tools are available to MPLAB X IDE and view or change their
paths:

* For Mac OS:
Access the build tools from mplab_ide>Preferences>Embedded>Build Tools from
the main menu bar.

* For Other OSs:
Access the build tools from Tools>Options>Embedded>Build Tools.

The window should automatically populate with all installed toolchains. If you do not
see your tool listed, try the following:

» Scan for Build Tools — Scans the environment path and lists the language tools
installed on the computer.

» Add — Manually add the tool to the list by entering the path to the directory
containing the tool executable(s), i.e., base directory. Typically, this is the bin
subdirectory in the tool installation directory.

If you have more than one version of a compiler available, select one from the list.
Ensure that the XC32 toolchain is selected for this tutorial.

FIGURE 3-11: LANGUAGE TOOL (COMPILER) LOCATIONS
' Options
% B a 8B € -
I General Editor Fonts & Colors Keymap cfc++ Embedded | Miscellaneous

Build Tools | Project Options I Generic Settings I Suppressible Messages I Oﬂ'1er|

Toolchain:

C18 (v3.43) [C:\Program Files (x86)
C32 (v2.02) [C:\Program Files (x86)
mpasm (v5.47) [C:\Program Files (x&

mpasm (v5.46) [C:\Program Files (x3| TYPe: ¥C32

XC16 (v1.10) [C:\Program Files (x858] Base Directory: |C:\Program Files (x86)WMicrochippec32\v 1. 111bin

XC32 (v1.11) [C:\Program Files |

%C8 (v1.11) [C:\Program Files (x86)Y C Compiler: C:\Program Files (x86)Microchipxc32\w 1. 11\bin\xc32-goc.exe

C++ Compiler: |C:\Program Files (x86)Microchiplxc32iv 1. 11%bin'xc32-g++.exe

Assembler: C:\Program Files (x86) Microchip'wc32iw 1. 11\bin'xc32-as.exe

HOBE

= Make Command: |C:\Program Files (x86) Microchip MPLABX \gnuBins\GnuwWin32'binimake . exe

( Add...

Remove

&) [
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3.3.6 Add An Existing File to the Project

For this tutorial, you will use existing example code:
* Go to the Explorer 16 Development Board web page on the Microchip web site:
http://www.microchip.com/explorer16

* Click “PIC32 Explorer 16 LED Example Application” to download the ZIP file
containing the example code.

» Once downloaded, unzip the project.
* Move the file 1ed message. c to the project directory (MyXProject.X).

Existing files can be added to a project by doing one of the following:

* Right clicking on the project in the Project/File window and selecting “Add Existing
Item”

* Right clicking on a logical folder (e.g., Source Files) in the Project/File window and
selecting “Add Existing Item”

When adding a file, you can choose whether to add it as:

» Auto — Let MPLAB X IDE decide how best to locate the file.

 Relative — Specify the file location relative to the project. (Recommended: Relative
paths will help portability when moving a project to another computer.)

» Absolute — Specify the file location by an absolute path.
» Copy — Copy the specified file to the project folder.

The file will appear in the File pane under the project specified and a tab with the file’s
name will appear in the Editor pane.

FIGURE 3-12: LED MESSAGE.C IN FILE PANE

: Projects <l & |: Files : Classes Start Page =2 'Elled_message.c B
=[5 MyProject L 51 &

+ﬁ Header Files
+ﬁ‘ Important Files
+ﬁ Linker Files
—ﬁ Source Files

- @ led_message.c
+E‘ Libraries

+ﬁ;‘ Loadables

{1

o - T S P N

e
=T
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Code Listing for 1ed message.c:

/*********************************************************************

*

*

*

Message via 8 LEDs

khkkhkhkhkhkhkhhkhkdhkhkdkhkhkdbhkhkdhbhkhkdrhhhkdhkhkdhkhkdhkdhkrkdbrhkdrhdrkdhhkdhkddrkdhkrkdrhkdxhdxk

/*
* %
* %
* *
* *
* *
* %
* %
* %

* %

*/

FileName: led message.c
Dependencies:p32xxxx.h

Processor: PIC32
Complier: MPLAB C32
MPLAB IDE v8.0+
Company : Microchip Technology, Inc.

Software License Agreement

The software supplied herewith by Microchip Technology Incorporated
(the “Company”) for its PIC32 Microcontroller is intended

and supplied to you, the Company’s customer, for use solely and
exclusively on Microchip PIC32 Microcontroller products.

The software is owned by the Company and/or its supplier, and is
protected under applicable copyright laws. All rights are reserved.
Any use in violation of the foregoing restrictions may subject the
user to criminal sanctions under applicable laws, as well as to
civil liability for the breach of the terms and conditions of this
license.

THIS SOFTWARE IS PROVIDED IN AN “AS IS” CONDITION. NO WARRANTIES,
WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING, BUT NOT LIMITED
TO, IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE APPLY TO THIS SOFTWARE. THE COMPANY SHALL NOT,
IN ANY CIRCUMSTANCES, BE LIABLE FOR SPECIAL, INCIDENTAL OR
CONSEQUENTIAL DAMAGES, FOR ANY REASON WHATSOEVER.

$Id: led message.c 5898 2007-10-23 19:39:48Z rajbhartin $

*******************************************************************/

Message in a bottle

Explorerlé version (long delays)

Thanks to Lucio DiJasio for letting us use this example.
Run this example on Explorer-16 board with PIC32MX PIM.

Hold the board vertically from the PICtail connector size
and wave the board back-and-forth to see message "HELLO" on LEDs

#include <p32xxxx.h>

Config settings

POSCMOD = HS, FNOSC = PRIPLL, FWDTEN = OFF
PLLIDIV = DIV 2, PLLMUL = MUL 16

PBDIV = 8 (default)

Main clock = 8MHz /2 * 16 64MHzZ
Peripheral clock = 64MHz /8 = 8MHz
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// Configuration Bit settings

// SYSCLK = 64 MHz (8MHz Crystal/ FPLLIDIV * FPLLMUL / FPLLODIV)

// PBCLK = 8 MHz

// Primary Osc w/PLL (XT+,HS+,EC+PLL)

// WDT OFF

// Other options are don't care

//

#pragma config FPLLMUL = MUL 16, FPLLIDIV = DIV_2, FPLLODIV = DIV 1,
FWDTEN = OFF

#pragma config POSCMOD = HS, FNOSC = PRIPLL, FPBDIV = DIV_8

// 1. define timing constant
#define SHORT DELAY (50%*8)
#define LONG_DELAY (400*8)

// 2. declare and initialize an array with the message bitmap
char bitmap[30] = {

oxff,// H
0x08,
0x08,
oxff,

0,

0,
oxff,// E
0x89,
0x89,
0x81,

0,

0,
oxff,// L
0x80,
0x80,
0x80,

0,

0,
oxff,// L
0x80,
0x80,
0x80,

0,

0,
0x7e,// O
0x81,
0x81,
0x7e,

0,

0

}i

// 3. the main program
main ()
{
// disable JTAG port
DDPCONbits.JTAGEN = 0;

// 3.1 variable declarations
int i; // 1 will serve as the index
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// 3.2 initialization
TRISA = 0; // all PORTA as output
T1CON = 0x8030; // TMR1l on, prescale 1:256 PB

// 3.3 the main loop
while( 1)
{
// 3.3.1 display loop, hand moving to the right
for( i=0; 1<30; i++)
{// 3.3.1.1 update the LEDs
PORTA = bitmapl[i];

// 3.3.1.2 short pause
TMR1 = O0;

while ( TMR1 < SHORT_DELAY)
!

} // for i

// 3.3.2 long pause, hand moving back to the left
PORTA = 0; // turn LEDs off

TMR1 = 0O;

while ( TMR1l < LONG_ DELAY)

{

}

} // main loop
} // main
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3.3.7 Editor Usage

The sample code should not need to be edited. However, when you need to edit your
code, you will be using the NetBeans editor. General information on this editor is avail-
able from the table of contents under the NetBeans help topic IDE Basics>Basic File
Features. C compiler information regarding the editor is available from the table of con-
tents under the NetBeans help topic C/C++/Fortran Development>C/C++/Fortran Proj-
ect Basics>Navigating and Editing C/C++/Fortran Source Files. A list of features is
available under Chapter 7. “Editor”.

To use editor features, go to the:

+ Edit menu (see Section 11.2.2 “Edit Menu”.)
+ Editor toolbar located at the top of each file's Editor window.
» Window right click (context) menu.

FIGURE 3-13: EDITOR TOOLBAR

|513rtP'age E|E|Ied_message.c a|

ER-P-eeaSfBeelexuo o

1%

2

3.3.8 Configuration Bits

In the sample code, Configuration bits are already set. For your own application, you
must set up the Configuration bits.

You must set Configuration bits in code. However, you can temporarily change Config-
uration bits during a debug session in the Configuration Bits window (Window>PIC
Memory Views>Configuration Bits). Then you may export the setting by right clicking in
the window and selecting “Generate Source Code to Output”. You can copy this code
from the Output window into your code.

For a summary of Configuration bits settings for different devices, see Appendix
A. “Configuration Settings Summary”.
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3.4 RUNNING AND DEBUGGING CODE

The following information discusses using the MPLAB X IDE to run or debug your code.

3.41 Build a Project

For MPLAB X IDE, it is not necessary to build the project first and then run or debug.
Building is part of the run and debug processes. For initial development or major
changes, however, you may want to make sure that the project builds before attempting
to run or debug.

To build a project:

* In the Projects window, right click on the project name and select “Build”. You may
also select “Clean and Build” to remove intermediary files before building.

+ Click on the “Build Project” or “Clean and Build Project” toolbar icon.

':E“ Build Icon

E‘E’"}’ Clean and Build Icon

Build progress will be visible in the Output window (lower right hand corner of the
desktop.) For this tutorial, the code should build successfully.

FIGURE 3-14: OUTPUT SUCCESSFUL BUILD

: Output - MyProject (Build, Load) F® | Tasks
make —-f nbproject/Makefile-default.mk SUBPROJECTIS= .build-conf -
u> make[l] : Entering directory “C:/Users/c08227.MCHP-MAIN/MPLABXProjects/MyProject X'
make -f nbproject/Makefile-default.mk dist/default/production/MyProject_X_production_hex
mzke[Z]: Entering directory “C:/Users/c03227.MCHE-MAIN/MPLABHProjects/MyProject X'

"C:y\Program Files (xz8€)\Microchiphxe32hwvl.ll \bin\xc3Z-goc.exe™ -g -x o —-c -mprocessor=32ZMH3E0F
"C:\Program Files (xB6)‘\Microchip'xc3Z\vl.ll\bin\xc3Z-gcc.exe™ -mprocessor=3ZME3€0F51ZL -o
"C:\Program Files (xz86)‘\Microchipixc32'wvl.ll\bin"\\xc3Z-binZhex dist/default/production/MyProj -
make[2]: Leaving directory “C:/Users/c08Z27.MCHE-MAIN/MPLABHProjects/MyProject X' T
make[l]: Leaving directory “C:/Users/c08227.MCHE-MAIN/MPLABHProjects/MyProject X'

BUILD SUCCESSFUL (totzl time: &s3)

Loading code from C:/Users/c082Z7 MCHP-MAIN/MPLABXProjects/MyProject.X/dist/default/production|
Loading symbols from C:/Users/c08Z27 MCHP-MAIN/MPLABXProjects/MyProject K/ /dist/default/product|
Loading completed

4 | i r

To view checksum information:

Open the Dashboard window (Window>Dashboard) if it is not already open to see the
checksum after a build.
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3.4.2 Run Code

Once the code builds successfully, you can attempt to run the application. Click on the
“Make and Program Device Project” icon (or select Run>Run Project) to run your
program.

%‘ Make and Program Device Project Icon

The lights on the demo board should be flickering. Wave the board back and forth to
see the word, “Hello”.

Run progress will be visible in the Output window as well.
Use the Hold in Reset button to toggle between device Reset and running.

%q“ﬂ Hold in Reset Icon

You can add a “Run Project” icon to the toolbar if you wish
(View>Toolbars>Customize).

|> Run Icon

343 Debug Run Code

For this tutorial, the code used has been tested and runs. However, your own code may
need to be debugged as you develop your application.

To Debug Run the tutorial code, click on the “Debug Project” icon (or select
Debug>Debug Project or Debug>Step Into) to begin a debug session.

|'§'_£> Debug Run Icon

Debug Run progress will be visible in the Output window.

To halt your application code:
Click on the “Pause” icon (or select Debug>Pause) to halt your program execution.
To run your code again:

Click on the “Continue” icon (or select Debug>Continue) to start your program
execution again.

To end execution of your code:

Click on the “Finish Debugger Session” icon (or select Debug>Finish Debugger
Session) to end your program execution.

For more details on debugging C code projects, see the NetBeans help topic
C/C++/Fortran Development>Debugging C/C++/Fortran Applications with gdb.

The difference between Run and Debug Run will become apparent when working with
debug features, beginning with Section 3.4.4 “Control Program Execution with
Breakpoints”.
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34.4 Control Program Execution with Breakpoints

When debugging code, it can be useful to suspend execution at a specific location in
code so that variable values can be examined. To do this, use breakpoints.

Set a breakpoint on the following line of code:

PORTA = bitmap[i];

To set a breakpoint on a line do one of the following:

+ Click the left margin of the line in the Source Editor
* Press Ctrl-F8

FIGURE 3-15: BREAKPOINT SET IN CODE

Start Page = |'P:‘Iled_message.c $| EB@
BPR-8-AETEFPL R e |4 = F
122 T1CCN = 0x8030; -
123
124
125 while({ 1)
126 {
127
128 for({ i=0; i<30; i+4+)
129 {
= PORTA = bitmap[i]:
131
132
133 IMR1 = 0O;
134 while ( TMR1 < SHORT_ DELRY)
135 {
136 1
137 L
138 -

m

Debug Run the tutorial program again. The program will halt at the breakpoint. Hover
over the bitmap [] variable to see its values.

FIGURE 3-16: PROGRAM EXECUTION HALTED AT BREAKPOINT

Start Page = |'Ig:"]Ied_message.c $| ’I‘B@
BR-B-AETEFPL | Ee | =

122 T1CCHN = 0x8030; -

123

124

125 while( 1)

126 {

127

128 for( i=0; i<30; i++)

129 {

= PORTA = bitmap[il;

L3 address = 0xA0000200, bitmap[0] = '

132 address = 0x40000201, bitmap[1] = "b'

133 THMR1 = 0O|address = 0xA0000202, bitmap[2] = "b'

134 while ( |address=0xA0000203, bitmap[3]="y

135 i address = 0xA0000204, bitmap[4] = "0 -

136 3 address = 0xA0000205, bitmap[5] = "0 I

137 ; address = 0xA0000208, b?tmap[ﬁ] =y

£ address = 0xA0000207, bitmap[7] = .. _
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To clear the breakpoint do one of the following:

* Repeat the step to set a breakpoint
» Select Debug>Toggle Breakpoint

For more on breakpoints, see the NetBeans help topics under
C/C++/Fortran Development>Debugging C/C++/Fortran Applications with gdb>Setting
C/C++/Fortran Breakpoints.

345 Step Through Code

Use one of the stepping functions on the Debug menu and Debug toolbar to move
through code either from the beginning of code or after a breakpoint halt. Examine
changes in variable values (see next section) or determine if the program flow is
correct.

There are several ways to step through code:

+ Step Over — Executes one source line of a program. If the line is a function call,
executes the entire function then stops.

+ Step Into — Executes one source line of a program. If the line is a function call,
executes the program up to the function’s first statement and stops.

» Step Out — Executes one source line of a program. If the line is a function call,
executes the functions and returns control to the caller.

* Run to Cursor — Runs the current project to the cursor’s location in the file and
stop program execution.

For more on stepping, see the NetBeans help topics under

C/C++/Fortran Development>Debugging C/C++/Fortran Applications with
qdb>C/C++/Fortran Debugging Sessions>Stepping Through Your C/C++/Fortran

Program.
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3.4.6 Watch Symbol Values Change

Watch the values of symbols that you select change in the Watches window. Determin-

ing if these values are as expected during program execution will help you to debug
your code.

To create a new watch:

1. Select Debug>New Watch. The New Watch dialog will open (see below).

2. Enter a Watch expression, in this case PORTA, and then click OK. The Watches
window will now appear on the desktop with the symbol.

OR

1. Right click on PORTA in code and select “New Watch”.
2. The Watches window will open with PORTA in it.

OR

1. Select Window>Debugging>Watches.
2. Drag and drop PORTA from the editor window into the Watches window.

FIGURE 3-17: WATCHES WINDOW WITH SYMBOL

xNewWatch | |

Enter or Select Watch Expression:

FORTR

() Global Symbols @ SFR's

[ OK ] [ Cancel ] [ Help ]
iWatches | & % |[; Variables : Call Stack |: Breakpoints |: output : Tasks
Name* Type Address Value
£5 B PORTA SFR () oxtrass010 (L] oxooooo4re L -
@ |:‘| <Enter new watch> E] E] E]
g‘;

To view symbol changes:

1. Debug Run and then Pause your program.

2. Click the Watches tab to view the window and see the symbol value. (Red text
means a change.)

For more on watches, see the NetBeans help topics under

C/C++/Fortran Development>Debugging C/C++/Fortran Applications with gdb>
Viewing C/C++/Fortran Program Information>Creating a C/C++/Fortran Watch.
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3.4.7

MPLAB X IDE has flexible, abstracted memory windows that provide a customizable
view of differing types of device memory. From a Memory window, you select the type
of memory and memory format in drop-down boxes.

View Device Memory (including Configuration Bits)

Begin by viewing Flash memory:
1. Select Window>PIC Memory Views>Execution Memory.
2. The Execution Memory window will open showing the last halt location.

FIGURE 3-18: MEMORY WINDOW CONTENT

: Execution Memory F # |: Watches : Qutput

e Line Address Opcode Label DisAszy

5‘ 8265 |9000. .. (34038030 CRI V1, ZERO, -32720

% 8266 |9D00. .. (AC430800 SW V1, 153&({V0)
8267 |9000. .. [AFCO0000 SW ZERO, 0(S58)

"' 8268 |9000... (OB4000SE J 0x8D000178

T 8269 |9000. .. (00000000 HOP

=20 2270 9000 022000 i 1 157 R

8271 |9000. .. (24430200 ADDIO V1, WO, 512
8272 |9000. .. (EFC20000 LW Vo, 0(S8)
8273 |9000... (00621021 ALDDT Vo, V1, VO
8274 |9000. .. (B0420000 IR Vo, 0{V0)
8275 |9000. .. (00401821 ADDT V1, Vo, ZERD

Change the memory view by:

» Selecting another window from the Window>PIC Memory Views list.
 Using the drop-down “Memory” menu on the window.

To set Memory window options:

Right clicking in the Memory window will pop up a menu with various options such as
display options, fill memory, table import/export and output to file. For more information
on this menu, see Section 12.8.13 “Memory Window Menu”.

To refresh the Flash Memory window:

1. Halt your program (Finish Debugger Session).
2. Click on the icon named “Read Device Memory”.

S

(T

Read Device Memory Icon
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3.4.8 Program a Device

Once your code is debugged, you can program it onto a target device.

First, you check the programming options in the Project Properties window. For this
tutorial, no options will be changed.

Second, you program the device in one of two ways:

 Click Run: The project is built (if necessary) and device is programmed. The pro-
gram will immediately begin execution on completion of programming.

» Click Make and Program Device: The project is built (if necessary) and device is
programmed. The program will NOT immediately begin execution on completion
of programming. You will need to disconnect the hardware tool from the target
board before the application will run.

Other programming-related functions are:

* Hold in Reset: Toggle the device between Reset and Run.
* Read Device Memory: Transfer what is in target memory to MPLAB X IDE.
Programming-related icons are:

|> Run Icon

Hold In Reset Icon

el sl

Make and Program Device Icon

Read Device Memory Icon

Note: Not all programming functions are in the MPLAB X IDE. For additional pro-

gramming support, see the MPLAB IPE included with the MPLAB X IDE
installation.
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NOTES:
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Chapter 4. Basic Tasks

41 WORKING WITH MPLAB X IDE PROJECTS
The following steps show how to work with projects in MPLAB X IDE

1. Before You Begin, install MPLAB X IDE, set up any hardware tools (install
@' USB drivers and properly connect to your target) and install language tools

s for your selected device. Then launch MPLAB X IDE and begin this tutorial.
Preliminaries

to the Desktop.
Create and Build a View or Make Changes to Project Properties in the Project Properties
Project dialog. Also Set Options for Debugger, Programmer or Language Tools in
the same dialog.
3. Set Language Tool Locations and Set Other Tool Options in the Tools
Options dialog.
4. Create a New File to add to your project or Add Existing Files to a Project.
Enter or edit your application code to the File window.
5. Discover other features for Editor Usage.
6. Add and Set Up Library and Obiject Files.
7. Set File and Folder Properties to keep or exclude individual files or entire
folders from the build.
8. SetBuild Properties for pre- and post-build steps and loading an alternative
hex file on build.
9. Build a Project.

@ 1. Create a New Project by using the New Project wizard. Then View Changes

N

—_

Run Code with the Run menu.

3

2. Debug Run Code with the Debug menu.
Execute Code
1. Control Program Execution with Breakpoints. Set breakpoints in-line or via
@ the Breakpoint window.
Debug Code 2. Step Through Code as the program executes.
3. Watch Symbol Values Change in the Watches and Variables windows.
4. View/Change Device Memory (including Configuration Bits). Memory types
are dependent on the device selected.
5. Use View The Call Stack to navigate function calls.
@ 1. Program a Device using simple toolbar buttons.

Program a Device
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4.2 CREATE A NEW PROJECT

MPLAB X IDE is project-based, so you must set up a project to work on your
application.

New projects can be created by selecting either:

+ Start Page, Learn and Discover tab, “Dive In”, “Create New Project”
* File>New Project (or Ctrl+Shift+N)

The New Project wizard will launch to guide you through new project set up.
421 Step 1: Choose Project

Step 1 will first ask you to choose a project category. In most cases you will choose a
project type from “Microchip Embedded”:

+ Standalone Project — Create a new C and/or assembly code project. This type of
project is shown in this section.

 Existing MPLAB IDE v8 Project — Convert your existing MPLAB IDE v8 project
into an MPLAB X IDE project. For details see Section 5.2 “Import MPLAB
Legacy Project”.

» Prebuilt (Hex, Loadable Image) Project — Load an existing project image into
MPLAB X IDE. For details, see Section 5.3 “Prebuilt Projects”.

+ Library Project — Create a new C and/or assembly code project that will build into
a library instead of executable hex file. For details, see Section 5.6 “Library
Projects”.

Other options are:

» Other Embedded Projects — Projects from other vendors.

» Sample Projects — Includes ready-to-use projects for different device families and
project templates for different device families.

Once you have made your selections, click Next> to move to the next dialog.

FIGURE 4-1: PROJECT WIZARD — CHOOSE PROJECT
x New Project : 3l
Steps Choose Project
1. Choose Project Categories: Projects:
2 .. Enl:ed:led [& standalone Project
. ..... )\ Other Embedded [&J Existing MPLAB IDE v8 Project

@ Prebuilt (Hex, Loadable Image) Project

- ) Samples
@ Library Project

Description:

Creates a new standalone application project. It uses an IDE-generated makefile to build your
project.

Finish Cancel | | Help
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422 Step 2: Select Device

Step 2 is where you select the device you will be using in your application from the
“Device” drop-down list. To narrow your selection list, chose a Family first. Click Next>.

FIGURE 4-2: PROJECT WIZARD - SELECT DEVICE
x New Project |i|
Steps Select Device

Choose Project
Select Device
Select Header Family:

Select ITAG Plugin Board
Select Compiler

Select Project Name and
Folder

Device:

A

2.

3.

4. Select Tool
5

]

7.

32-bit MCUs (PIC32)

PIC32MX 360

nish Cancel Help
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4.2.3 Step 3: Select Header

Step 3 will appear if a header is available for your selected device. To determine if a
header is required for debug or if your device has on-board debug circuitry, consult the
“Processor Extension Pak and Header Specification” (DS51292 or online help). Then
choose whether or not to use a header. Click Next> when done.

Note: You can select a header later (if one is available) using the Project Proper-

ties window.
FIGURE 4-3: PROJECT WIZARD - SELECT HEADER
x New Project RS
Steps Select Header

1. Choose Project

2. Select Device * OPTIOMAL: Please select an associated debug header if present

3. Select Header

4. Select Tool

5. Select Plugin Board Supported Debug Header: AC244035 -

6. Select Compiler

7. Select Project Name and

Folder A debug header is a device made espedally for debugging. It provides
extras pins and in some cases extra debugging capabilities.

< Back Finish Cancel Help
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424 Step 4: Select Tool

Step 4 involves selecting the tool.

Tool support for the selected device is signified by the colored circles (lights) in front of
the tool name. If you cannot see the colors, mouse over a light to pop up text about

support.
Light Color Support
10) Green Full (Implemented and fully tested)
) Yellow Beta (Implemented but not fully tested)
) Red None

For some tools, there are two lights next to the tool name, where the first light is the
left-most light and the second light is to the right of the first.

Light No. Debug Tools Simulator
1 Debugger Support Core (Instruction Set) Support
2 Programmer Support Peripheral Support

For the hardware tools, you will notice that a serial number (SN) is specified below any
tool that is connected to your computer. This allows you to select from several
connected hardware tools.

Select your tool and then click Next>.

FIGURE 4-4: PROJECT WIZARD - SELECT TOOL
x New Project | RS |
Steps Select Tool

. Choose Project
. Select Device | Hardware Tools -
. Select Header

. Select JTAG Plugin Board

. Select Compiler

. Select Project Name and
Folder

1
2.
3
4. Select Tool
5
6
7.

m

| Microchip Starter Kits

-@ MCHV

-@ MICROSTICK

-@ SKDE 33 AUDIO

-@ SKDE Memory

-@ SKDE PIC18F]

-@ SKDE PIC24F 1

i SKDF PIC24H SENSOR
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425 Step 5: Select Plug-In Board

For the MPLAB REAL ICE in-circuit emulator, you may specify a plug-in board to use.
A plug-in board is the circuit board that is inserted into the emulator’s driver board slot.

TABLE 4-1: EMULATOR PLUGIN BOARDS

Supported Plugin
Board

Board Description

None

Standard Communications driver board

None

High-Speed Communications driver board

JTAG Driver Board

JTAG Adapter board

Power Monitor Board

Power Monitor board (also inserts into logic probe connector)

Select your tool and then click Next>.

FIGURE 4-5: PROJECT WIZARD - SELECT PLUGIN
x New Project RS

Steps Select Plugin Board
1. Choose Project
2, Select Device * OPTIOMAL: Please select an associated plugin board if present
3. Select Header
4. Select Tool : . I
5. Select Plugin Board @pporh&d Plugin Board: Mone D
6. Select Compiler
7. Select Project Name and

Folder A plug in board is a daughter board for the REAL ICE that provides spedialized

debugging and/or programming features.
< Back Finish Cancel Help
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4.2.6

Step 6 involves selecting the language tool, either a C compiler or assembler. Again,
the colored circle (light) in front of the compiler name signifies the device support level.

Step 6: Select Compiler

Mouse over for text.

Note:

If you do not see your language tool listed, look under Tools>Options
(mplab_ide>Preferences for Mac OS X), Embedded button, Build Tools

tab, to ensure MPLAB X IDE can find the tool. If your tool is listed, then your
project device may not be supported by your tool. Consider selecting or
installing another language tool that supports the device.

TABLE 4-2:

MICROCHIP LANGUAGE TOOLS

Toolchain

Full Name

8-Bit Device Language Tools

MPASM* MPASM Assembler, MPLINK Object Linker and Utilities
c18* MPLAB C Compiler for PIC18 MCUs
HI-TECH PICC HI-TECH C Compiler for PIC10/12/16 MCUs

HI-TECH PICC18

HI-TECH C Compiler for PIC18 MCUs

XC8

MPLAB XC8 C Compiler

16-Bit Device Language Tools

ASM30** MPLAB Assembler, Object Linker and Utilities for PIC24 MCUs and
dsPIC DSCs

C30 MPLAB C Compiler for PIC24 MCUs and dsPIC DSCs

C24 MPLAB C Compiler for PIC24 MCUs (subset of C30)

dsPIC MPLAB C Compiler for dsPIC DSCs (subset of C30)

HI-TECH DSPICC

HI-TECH C Compiler for PIC24 MCUs and dsPICDSCs

XC16

MPLAB XC16 C Compiler

32-Bit Device Language Tools

C32

MPLAB C Compiler for PIC32 MCUs

HI-TECH PICC32

HI-TECH C Compiler for PIC32 MCUs

XC32

MPLAB XC32 C Compiler

MPASM.

* Most compilers come with an assembler, linker and utilities. MPLAB C18 is supported by

** No longer included with MPLAB X IDE in v1.30. Please use an assembler that comes with
one of the 16-bit compilers.

For more on each language tool, consult the language tool documentation.

For third party language toolchains (CCS, etc.), see the “Readme for Third Party
Tools.htm” file on the Start Page, “Release Notes and Support Documentation”.
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Select your tool and then click Next>.

FIGURE 4-6: PROJECT WIZARD - SELECT LANGUAGE TOOL
x New Project | 3
Steps Select C
1. Choose Project
2. Select Device . Compiler Toolchains
3. Select Header 2-c32
4. SelectTool . 1.0C32 (v2.02) [C:\Program Files (x86) Microchip MPLAB C32 Suite in]
5. Select JTAG Plugin Board .
6. Select Compiler .I TECH PICC32 (Mone found)
7. Select Project Name and (5:32 : :
Folder [eYC32 (v1.11) [C:\Program Files (x86) Microchipixc32iv 1. 11%bin]
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427 Step 7: Select Project Name and Folder

Step 7 involves selecting the project name, location and other project features. When
you are done, select Finish to complete new project creation.
Project Name, Location and Folder

Enter the project name. By default, the name will be appended with . X. This is not
required and simply a convention. You can delete this if you wish in the “Project Folder”
text box.

Browse to a folder location. You can create a new project folder if you need one. By
default, projects will be placed in:

* Windows XP — C:\Documents and Settings\UserName\MPLABXProject
* Windows 7/8 — C: \Users\UserName\MPLABXProjects

* Linux — /home/UserName/MPLABXProjects

* Mac — /Users/UserName/MPLABXProjects

However, you may choose to put them in your own location.

Main Project

Check “Set as main project” to specify this project as your main project.

Encoding

Select the encoding for the project. The default is ISO-8859-1 (Latin 1) character set.

This selection will specify the code syntax coloring, which can be edited under
Tools>Options (mplab_ide>Preferences for Mac OS X), Fonts and Colors button,

Syntax tab.
FIGURE 4-7: PROJECT WIZARD - SELECT PROJECT NAME AND
FOLDER
x New Project [ ]
Steps Select Project Name and Folder
1.  Choose Project
2. Select Device Praject Name: MyProject
3. Select Header
SV P o Project Location: C:\Users\c08227. MCHP-MAINVMPLABNProjects Browse...
67‘_ gif;tf;lp]":;t ey Project Folder: C:\Users\F08227, MCHP-MAIN\MPLASXProjects\MyProject.X
polder Overwrite existing project.
Alzo delete sources,
V| Set as main project
Enceding: [S0-8859-1 -
< Back ext > Finish ] | Cancel | ‘ Help
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4.3 VIEW CHANGES TO THE DESKTOP

Once you have created your project, several panes will open in the IDE.

* File pane — pane with four tabbed windows:
- The Projects window displays the project tree with files grouped by category.
- The Files window displays the project files according to the folder organization

on your computer.

- The Classes window displays any classes and their functions, variables and
constants in the code. Double click on an item to see its declaration.

- The Services window displays any services available to use for code develop-

ment.

* Navigator pane — displays information on the symbols and variables in the file

selected in the File pane.

» Editor pane — for viewing and editing project files. The Start Page also is visible

here.
» Task pane — displays task output from building, debugging, or running an
application.
FIGURE 4-8: MPLAB X IDE DESKTOP
€ MPLAE X IDE 195 - MyPraject : detault |
|File Edit View Neoigete Scarce Refoctor Run Depug Team Took Window Help
ka1 L N et ST WL @ | e | [
ﬁrn,m:u 4 # | Files : Classes -b"lﬁlﬂqu B ed_nessage.c ® EE
8 Hyfrogec k2 aesEeet awe 5/ 060
i [f[ vesdar Pies | I -
3 E Iregosrtani Fles [ ]-] fpragms config FPLLMUL = Z‘{'i.'._'.f\-_. FPLLIDEV = I"'.'.-'_.'-I FPLLODIV = I'II'-\.'_'.I D J
i) Lnker Fies CEI s conflg POSCHMOD = HS, FNOSC = PRAIFLL, FFEDIV = LIV _&
i) RN i
7 Lbrees 71
- Losdsties 72
73
il =)
5 {AO0=E)
78 L
"B -] char bitmap[30] = {
FILE PANE . e
l\-. | (51 tall®,
I?'G-pﬂrqmﬂ Daghb.. @ % | Source Files ww.."\l B2 OMEEL,
B2 '3 MyProject L O
- g D B4 o, EDITOR PANE
L i PICIMOEFS 1L Bs oxEr, -
= il Chedksur: e TDO3555 l\‘_ i 3 _,,.-"l
T Compler Togcrain S
™ 1 T Prochuction mage : NC33 (. 11} [C:Wrogram Fi | | 7TaakS i
L & Memary 1 Drescriplion B Lscamian
(B Rt 32768 {CeaE00) bytes
[ ™
5 RAM Used: 0 (I} Free: 32768 (Twa000) E
|:F-i' S36.560 (0wl 2P0} Byl
0% )
858 Flash s () {[oal) Free: E36560 (aFrD
EE Debug Tool =
00 A= ICE: DEFAILT
iF Dot Fesaroes
B Program BP Used; O Free; &
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DS50002027C-page 76

© 2011-2014 Microchip Technology Inc.



Basic Tasks

If you double click on any file name in the File pane, the related file will open in the Edi-
tor pane under a tab next to the Start Page. To close the tab, click on the “x” next to the
file name.

Right click on the project name in the File pane, Projects window, to view the pop-up
(context) menu. Do the same for the project’s subfolders.

44 VIEW OR MAKE CHANGES TO PROJECT PROPERTIES

Once a project has been created, you can view or change the project properties in the
Project Properties dialog. Access this dialog by either:

* Right clicking on the project name in the Projects window and selecting
“Properties”.

+ Clicking on the project name in the Projects window and then selecting
File>Project Properties.

Click the “Conf: [default]” category to reveal the general project configuration, such as
the project device, related debug/programmer tool, and language tool. To change any
of these items, refer to steps 4 and 5 of Section 4.2 “Create a New Project”.

FIGURE 4-9: PROJECT PROPERTIES DIALOG
x Project Properties - MyProject | PS |
Categories: Configuration
o @ General
S @ Family: Device:
i @ Real ICE All Families v |PIC32MX360F512L -
i~ @ Loading
@ Libraries Supported Debug Header: Supported Plugin Board:
: @ Building None None -
=k @ ¥C32 (Global Options)
xc32-as
Xxc32-gec Hardware Tool: Compiler Toolchain:
. Hardware Tools - . Compiler Toolchains
xc32-g++
-0 ICD 3 =032
xes2id 2 PICKiE2 -0 €32 (v2.02) [C+\Program Fies (x36)\)
-0 PICKit3 ~HI-TECH PICC32 (Mone found)
-0 PM3 —I-XC32
[ eF ol T
@0 Simulator C
Ei- 4 Microchip Starter Kits
L@ MCHY
- MICROSTICK
: SKDE 33 AUDIO
0 SKDE Memory
| @ SKDE PIC18F)
- SKDE PIC24F 1
_ SKDE PIC24H SENSOR
L SKDE PIC32 a4 L) G
*Tip: double dick on serial number (SN) to use a friendly name (FN) instead.
Manage Configurations. .,
[ OK I | Cancel | | Apply | | Help
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4.5 SET OPTIONS FOR DEBUGGER, PROGRAMMER OR LANGUAGE TOOLS

Additionally, you set options for your tools in the Project Properties dialog.
To set up or change debugger/programmer tool options:

Click on your hardware tool or simulator (beneath Conf:[default]) to see related set up
options. For more on what these options mean, see your tool documentation.

FIGURE 4-10:

TOOL SETUP PAGE

e B
=)

@
@
e @ Building
B @

General
Conf: [default]

Loading
Libraries

¥C32 (Global Options)
i @ xc32-as
i@ XC32-goc

@ xc32g++
e @ xe324d

Options for Real ICE

Option categories: | Memories to Program

Categories:

a

==

Wuto select memories and ranges

Allow Real ICE to Select Memories

—

Configuration Memery {always programmed in deb...|

Boot Flash (always programmed in debug mode)

Program Memory

Manage Configurations...

Program Memary Start (hex) (Ox1d000000
Program Memory End  (hex) Ox 1d07F
Preserve Program Memory |:|
Preserve Program Memory Start (hex) O 1d000000
Freserve Program Memory End  (hex) O 1O FFFFF
Option Description
Ok ] [ Cancel ] [ Apply ] [ Help
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To set up or change language tool options:

Click on your language tool to see related setup options. For more on what these
options mean, see your language tool documentation.

See the NetBeans help topic C/C++/Fortran Development>Working with C/C++/For-
fran Projects>Setting Project Properties for additional help.

FIGURE 4-11: LANGUAGE TOOL SET UP PAGE

B
Categories: o for we32- 1.19)
o g — ptions for xc32-gee (v1.
Bl @ Conf: [defaul] Option categories: | General -
i @ Real ICE
. Loading Have symbols in production build &
Libraries Enable App IO &
Buildin
8 . solate each function in a section E
¥C32 (Global Options)
i 0 xc32as Place data into its own section |}
[0) Use indirect calls [ =
- @ xc32g++
Generate 16-bit code
@ xc324d ]
Exclude floating-point library =
Preprocessor macros [
ncdude directories [l -
Additional options:
Option Description | Generated Command Line
Manage Configurations...
OK. ] [ Cancel ] [ Apply ] [ Help
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46 SET LANGUAGE TOOL LOCATIONS
To see what language tools are available to MPLAB X IDE and view or change their
paths:

* For Mac OS X — Access the build tools from:
mplab_ide>Preferences>Embedded>Build Tools from the main menu bar.

* For Other OS - Access the build tools from:
Tools>Options>Embedded>Build Tools.

The window should automatically populate with all installed toolchains.

FIGURE 4-12: LANGUAGE TOOL (COMPILER) LOCATIONS
' Options
% B a B ¢ |»
B General Editor Fonts & Colors Keymap cfc++ Embedded | Miscellaneous

Build Tools | Project Options I Generic Settings I Suppressible Messages I Oﬂ'1er|

Toolchain:

C18 (v3.43) [C:\Program Files (x86)
C32 (v2.02) [C:\Program Files (x86)
mpasm (v5.47) [C:\Program Files (x&

mpasm (v5.46) [C:\Program Files (x3| TYPe: ¥C32

XC16 (v1.10) [C:\Program Files (x858] Base Directory: |C:\Program Files (x86)WMicrochippec32\v 1. 111bin

XC32 (v1.11) [C:\Program Files |

%C8 (v1.11) [C:\Program Files (x86)Y C Compiler: C:\Program Files (x86)Microchipxc32\w 1. 11\bin\xc32-goc.exe

C++ Compiler: |C:\Program Files (x86)Microchiplxc32iv 1. 11%bin'xc32-g++.exe

HOBE

Assembler: C:\Program Files (x86) Microchip'wc32iw 1. 11\bin'xc32-as.exe

Make Command: |C:\Program Files (x86) Microchip MPLABX \gnuBins\GnuwWin32'binimake . exe

o ) (o ] [

461 Add or Change a Toolchain

If you do not see your tool listed under Toolchains, try the following:

» Scan for Build Tools — Scan the environment path and list the language tools
installed on the computer.

+ Add — Manually add the tool to the list by entering the path to the directory
containing the tool executable(s), i.e., base directory. Typically, this is the bin
subdirectory in the tool installation directory.

If you have more than one version of a compiler available, select one from the list.
To change the path of a tool, enter the new path or browse for it.
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4.6.2 About Toolchain Paths

MPLAB X IDE searches for toolchains under default installation paths and the PATH
environmental variable. An example default path for MPLAB XC16 under a Windows
64-bit operating system is:

C:\Program Files (x86)\Microchip\xclé\bin

When you install a compiler, you have the choice to:

1. install at the default location or at a different location
2. add the location to the PATH

If you are installing at a location different from the default, you should add that location
to the PATH.

If you do not choose to have the installer add a new location to the PATH, you can point
MPLAB X IDE to the compiler location in Tools>Options, Embedded button, Build
Tools tab, by clicking Add.

Finally, you can manually add the new location to the PATH variable.

4.7 SET OTHER TOOL OPTIONS

In addition to the build paths, you may set up other options. Select from the following
tabs in the Options window, Embedded category:

» Project Options — Set project-related options, such as make options and whether
paths are defaulted to relative or absolute (Section 12.12.2 “Project Options
Tab”).

» Generic Settings — Set up the log file and other project features
(Section 12.12.3 “Generic Settings Tab”).

» Suppressible Messages — Select messages to be suppressed
(Section 12.12.4 “Suppressible Messages Tab”)

» Other — Edit the lists of accepted file extensions for C source files and header files
(Section 12.12.6 “Other Tab”).
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4.8 CREATE A NEW FILE

New files can be created by doing one of the following:

+ Selecting File>New File (or Ctrl+N)

* Right clicking on the project in the Project/File window and selecting New>QOther

* Right clicking on a logical folder (e.g., Source Files) in the Project/File window and
selecting New>Other

A New File Wizard with launch to guide you through new file set up.

Step 1. Choose File Type: Choose the file category by expanding “Microchip Embed-
ded” to find an appropriate selection. Then select a file type.

FIGURE 4-13: FILE WIZARD — CHOOSE CATEGORY AND TYPE
3K New File [ =]
Steps Choose File Type
;. Choose File Type Project: | G MyProject hd
Categories: File Types:
= r_' Microchip Embedded - E‘] mair. c
; ASM30 Assembler
C18 Compiler
C30 Compiler

m

C32

[} HL-TECH Compiler
> ) MPASM assembler
> ) XC16 Compiler
) XC8 Compiler

..... ), C++ -

Description:
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Step 2. Name and Location: Name the file and place it in the project folder.

FIGURE 4-14: FILE WIZARD - CHOOSE ASSOCIATED PROJECT
x New main.c RS
Steps Name and Location
1. Choose File Type File Mame: |MyFile
2. Name and Location
Extension: |c -
Set this Extension as Default
Project: MyProject
Folder: Browse...

Created File: |C:\Users\c08227. MCHP-MAINYMPLABXProjects\MyProject. X \MyFile.c

< Back Mext > Cancel

The file will appear in the File pane under the project specified and a tab with the file’s
name will appear in the Editor pane. Enter your file content under this tab. The text in
the file will have syntax color based on its file type.

FIGURE 4-15:

NEW FILE — MYFILE.C

: Projects < & | Files

|ECIasses Start Page KHE:‘] MyFilec =
-G MyProject | - .|ﬁ = .5'| P

+E Header Files =
+ﬁ‘ Important Files 2
+E Linker Files 3
—[aﬁ Source Files 4
] MyFile.c 5
+ﬁ' Libraries el L
+ﬁ1‘ Loadables 7

g

g

10

11

12
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49 ADD EXISTING FILES TO A PROJECT

Existing files can be added to a project by doing one of the following:
* Right clicking on the project in the Project/File window and selecting “Add Existing
ltem”

* Right clicking on a logical folder (e.g., Source Files) in the Project/File window and
selecting “Add Existing Item”

4.9.1 Files in Project Folder

When adding a file, you can choose whether to add it as:

» Auto — Let MPLAB X IDE decide how best to locate the file.

* Relative — Specify the file location relative to the project. (Most portable project.)
» Absolute — Specify the file location by an absolute path.

» Copy — Copy the specified file to the project folder.

The file will appear in the File pane under the project specified and a tab with the file’s
name will appear in the Editor pane.

4.9.2 Files Outside of Project Folder

When adding a source file that is not in the project folder, add the file as “Relative”. This
will create an external folder (_ext) so the project can find the file when building.

To make use of navigation features such as //TODO and file context menus, you must

tell the project where the files are located. To do this:

1. In the Projects window, right click on the project name and select “Properties”.

2. Under “Categories”, click “General”.

3. Next to “Source Folders”, click Add.

4. Browse to the path to the external file(s) you have added to the project. Select
Select.

5. Click Apply or OK. Then rebuild the project.

When you import an MPLAB IDE v